Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Could not apply/close the dialog in a component after browser resize

samsundar23
Level 4
Level 4

Could not apply/close the dialog in a component after browser resize. Please find the below steps.

  1. Open the page
  2. Resize the browser window
  3. Open the dialog (dialog occupies the entire browser)
  4. Apply/Close the dialog

Other stakeholders say, this must a problem after SP7 upgrade. But when I checked in local (which is not having SP7) the same problem exist.

Actual result:

  • The apply/close button in dialog is not working

Expected result:

  • The dialog should apply new changes or close the dialog.

 

samsundar23_0-1617811639613.png

 

Thanks

SHYAMSUNDAR TK

 

Topics

Topics help categorize Community content and increase your ability to discover relevant content.

6.5
0 Replies
Singaiah_Chintalapudi
Community Advisor
Community Advisor

Are you using the AEM 6.5.7 (SP7) any specific browser/OS? I don't see this issue on AEM 6.5 (SP5).

 

Thanks,

Singaiah

asutosh_jena
Community Advisor
Community Advisor

Hi @samsundar23 

Is this issue reproducible on all components or only on a specific component? I tried the check the same on we-retail and wknd components and do not see this issue.

After resizing the browser, the dialog remains unchanged. I tried to resize both vertically and horizontally, but no issue observed.

 

If this is happening only on some specific component then you might need to check with the dialog structure as well as the CSS that is loading which might be having some issue. Can you reproduce the same issue on wknd or we-retail website on your instance?

 

Let me know if I am missing anything here.

 

Thanks!

rush_pawan
Community Advisor
Community Advisor

Hello,

 

Did you observe any error in browser console log while loading the dialog or on click of apply/close button. Normally, it shouldn't be an issue until unless something failing like you may have created some custom library for dialog handling and its part of AEM OOTB library and now its breaking the framework library correctly or similar (just not to oversee).

 

so check that as well.

 

thanks!!

samsundar23
Level 4
Level 4

Hi @rush_pawan 

Thanks for the suggestion.

Please find my findings;

  • No error in the browser console which could give us any lead of the root cause.
  • The same issue doesn't happen in any other component.
  • I removed the clientlib completely and checked if in case because of the custom clientlib implemented.
    But the same issue does exist.

Kindly let me know.

 

Regards
SHYAMSUNDAR TK

PulkitJain
Employee
Employee

@samsundar23 This issue is not reproducible with SP8, either. Seems to be an issue specific to the component/one in the screenshot.

If there are no errors in the console, please log a support ticket for a screenshare session to troubleshoot further.

SameerDhawan
Level 3
Level 3

Hi @samsundar23 ,

This is OOTB Component or Custom Component ?

Have you tried re-building the client-libs ? Please try and see if that makes any difference.

 

- Sameer