Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

AEM Forms 6.4 JEE - Configure SOAP Web Service Data Source

Avatar

Level 2

Hi,

when trying to configure a SOAP Web Service as a data source in AEM Forms 6.4 it's not possible to enter the authentication data although it's possible to select the authentication type i.e. there are no forms fields to enter the authentication information.For the particular case we were selecting Basic Authentication.

In 6.3 one was presented with form fields to enter the data.

Am I missing something?

AEM Forms 6.4 JEE on Windows Server 2016

IE 11

BR

Maruan

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

This is a known issue and will be fixed in 6.4.1. You may bookmark AEM Forms releases page for the update.

DarrenBiz has mentioned the path already where you need to set the values, you can easily contemplate properties and values if you have 6.3.

View solution in original post

0 Replies

Avatar

Employee Advisor

Hi Maruan,

I will check and confirm you on this by tomorrow. Meanwhile, you can try adding the values for the authentication directly in the cloud services node.

Avatar

Level 7

I also don't see any authentication fields for SOAP using Basic Auth either. If you select the REST option, you do see username/password fields appear in Step 2 of configuring the Create Data Source Configuration.

Avatar

Level 2

I'll try selecting the REST option and let you know if the fields are being displayed when I'm back at work

Avatar

Level 2

Thank you - could you give me a hint where the cloud services nodes are stored?  I was quickly looking for it but couldn't find it.

With kind regards

Maruan

Avatar

Level 7

As Mayank Gandhi​ mentioned, you could add the nodes to the configuration manually in CRXDE. You would have to know what the username and password property names are beforehand because they aren't created when the config is created. They should be the same as AEM 6.3 and probably the same as REST Basic Auth properties.

The configs are located in /conf/<cloud_config_name>/settings/cloudconfigs/fdm/<cloud_service_name>/jcr:content

Avatar

Correct answer by
Employee Advisor

This is a known issue and will be fixed in 6.4.1. You may bookmark AEM Forms releases page for the update.

DarrenBiz has mentioned the path already where you need to set the values, you can easily contemplate properties and values if you have 6.3.

Avatar

Employee Advisor

Hi Darren,

Seem to be existing in case of SOAP only and the fix would be delivered on 6.4.1 for the same.

Avatar

Level 2

Thank you both for the information and your support. Would you have a tentative schedule for 6.4.1?

- I can confirm that the issue is for SOAP only. Choosing REST the fields to enter the credential are there

- I tried replicate the same setting for 6.4 as one can enter using the 6.3 GUI using CRX explorer but that didn't work. I might have missed something.

The workaround I put in place was doing an AEM orchestration process using workbench to do an authenticated call to the SOAP web service and doing an unauthenticated call from the Adaptive Form to the AEM orchestration (setting the security to off for that process) which works fine so using the orchestration as a proxy.

Might serve as a workaround for others where AEM Forms JEE is in place for the time being.

Avatar

Employee Advisor

That's a good workaround Maruan and the fix would be out in 2 weeks for the issue. You may check the release doc that I shared earlier to get the download link directly.

Thanks!

Avatar

Employee Advisor

AEM forms 6.4.1 is publically available. Please find the reference link below to obtain the direct link for 6.4.1 forms add-on package:

AEM Forms releases

Avatar

Level 2

Thanks for sharing the information. We'll try early next week and provide feedback if the issue is resolved.

btw great support here!

Avatar

Level 2

Hi,

we've updated to 6.4.1 and the Authentication dialog is available now. Unfortunately it seems that the authentication is only used for the call itself but not when requesting the WSDL - is that correct? Accessing the WSDL also needs an authentication (trying to access a SAP system) at the customers site.

With kind regards

Maruan

Avatar

Employee Advisor

Yes, the call is for authenticating just the service.

Can you please elaborate the use case.

Avatar

Level 2

There is no specific use case other than all access to SAP resources is password protected so in order to get the WSDL an authentication is neccesary which is the same as authenticating for the call itself. BTW. the customer is trying to migrate PDF forms to Adapative Forms. Defining the Webservice in AEM Forms Designer works just fine.