Replies

Avatar

Avatar

ashu4pma

Avatar

ashu4pma

ashu4pma

03-06-2018

I didn't get this, What update exactly you are looking for? As I have mentioned in first reply, it is a security request filter at sling level responsible for this, uncheck the option (Enable Content Disposition for all paths) at filter takes you to the old behavior. It is a not a bug rather security improvement.

Avatar

Avatar

anudeepyeleti

Avatar

anudeepyeleti

anudeepyeleti

04-06-2018

I was looking for the possible reason for the assets being downloaded rather than being displayed in the browser in AEM 6.4 .

I have observed this with all the images and  this was never the case with AEM 6.1 .

I did look at the Enable Content Disposition for all paths option in Apache Sling Content Disposition Filter, but I do not see any differences between AEM 6.1 and 6.4 at a quick glance.

The Enable Content Disposition for all paths option is always checked by default.

Why is it that it needs to be unchecked to expect the old behavior while it is not recommended to uncheck this option.

I would like to know if there is more to this and just this option in content disposition filter.

Avatar

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K

Avatar

smacdonald2008

Total Posts

12.7K

Likes

1.4K

Correct Reply

2.3K
smacdonald2008

04-06-2018

As our Adobe Team member stated - is a sling security option - that is all.

"it is a security request filter at sling level responsible for this"

Avatar

Avatar

Ravi_S

Avatar

Ravi_S

Ravi_S

26-11-2018

Circling back to this thread here. PDF's are downloading on to a local browser. Updating/Disabling the disposition filters are not helping either? What else do i need to do?

Avatar

Avatar

bsloki

MVP

Avatar

bsloki

MVP

bsloki
MVP

29-11-2018

Hi,

Ideally you should use any of the players like HTML5 player to render your video on the browser. when someone access an asset (including video) directly then ideal behavior is to download.

Avatar

Avatar

ignacio_mancill

Avatar

ignacio_mancill

ignacio_mancill

07-12-2018

Any update here?

I tried to add a robots.txt and it is being downloaded yet. I know that there are different ways to show a robots.txt but the simpliest way is to put in the dam and just configure a rule mapping, but this easiest way does not work because this issue.

Does anyone has solved it?

Avatar

Avatar

arvindp66202646

Avatar

arvindp66202646

arvindp66202646

21-01-2020

Dear Team,

 

I am facing same issue in AEM 6.5 (without any service packs). I tried all possible tricks with Content Disposition filter like check/uncheck flag , putting proper values in included resource paths , but still it downloads my video assets rather than streaming in browser.

I am referring video assets through direct DAM link .

 

May I request if someone can be able to help me out here .

 

Thanks in advance.

 

Avatar

Avatar

ravim10791202

Avatar

ravim10791202

ravim10791202

20-02-2020

We recently upgraded from 6.3 to 6.5 and facing the same issue. The pdf files, robot.txt and sitemap.xml were opening on the browser window on 6.3 version is downloading the files on 6.5 version. I have tried unchecking the "Enable For All Resource Paths" on the content disposition filter and also added the absolute path on "Included Resource Paths & Content Types" fields. Nothing works. Does anyone have solution??

Avatar

Avatar

Riju_Mahana

Avatar

Riju_Mahana

Riju_Mahana

26-02-2020

I used the solution for PDF's from this thread. It works only via a dispatcher, though. But it works like a miracle.

https://experienceleaguecommunities.adobe.com/t5/Adobe-Experience-Manager/PDF-from-dispatchers-shoul...

 

The Disposition Filter in AEM is pretty useless (and pathetic) for all these scenarios. Not sure what is the purpose of that filter.

Avatar

Avatar

vik-kim

Avatar

vik-kim

vik-kim

09-03-2020

Thanks! I finally found a solution for robots.txt issue. Actually it works for all types of assets, just need to change pdf to your format (e.g. txt, png, mp4, etc).