Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Personalization block issues

Avatar

Level 5

Hi Team,

We have a issue with the personalization blocks , we did the Adobe Campaign Upgrade from v6.0.2 to v6.1.1 (Latest Build), before the upgrade things were going good, but now we face issues with the schema's and now it is with personalization blocks.

Earlier we have the custom recipient schema defined in one of our optout views which is as below

<%

if( document.mode != 'forward' ) { %>

<P><FONT style="FONT-SIZE: 10px; FONT-FAMILY: Verdana, Arial"> <%= recipient_custom.@Email%>. <a href="<%@ include option='NmsServer_URL' %>/webApp/VWKUnsubWebAppcustom?id=<%=escapeUrl(reversibleCrypt(recipient_custom.id))%>" _type="optout" _label="Opt-out link">click</A>.</FONT></P><%

}%>

the above code is being used in the javascript template in turn used in publication model, Fristly the opt out web app is working as expected. But the personalization code - <%= recipient_custom.@Email%> is not working. If i remove this block i am able to send the deliveries out, But customer is asking to have this code in place as it was before , since it is a opt out web app we want this to be solved at the earliest.

Requesting for an help here.

1 Accepted Solution

Avatar

Correct answer by
Level 5

Hi Florentlb,

I made couple of tests and of them one I created a new and used the same personalization block as above which was having issue.-- This did not work.

Later changed to  &lt;%= custom_recipient_scheman.Email %&gt; in the new personalization block which worked fine.

View solution in original post

7 Replies

Avatar

Employee

HI Adithya,

Do you have this schema and personalization available after the upgrade.

Do you see any conflicts after the upgrade which needs to be resolved

Thanks

Shrawan

Avatar

Level 5

Hi,

Yes the schema is available and post upgrade we resolved all the conflicts and during that time we did not encounter conflicts with this custom recipient schema.

Thank you,

Adithya

Avatar

Level 10

Did you try to recreate the exact same block from scratch? Sometimes that works with other objects, not sure about personalization blocks though.

Also, please let us know if you find some things or any solution from support.

Florent

Avatar

Correct answer by
Level 5

Hi Florentlb,

I made couple of tests and of them one I created a new and used the same personalization block as above which was having issue.-- This did not work.

Later changed to  &lt;%= custom_recipient_scheman.Email %&gt; in the new personalization block which worked fine.

Avatar

Level 10

Hi,

Did you try to contact support to check this more in-depth and make sure that this is not coming from a technical change or problem in the product after your upgrade?

Florent

Avatar

Level 5

Hi Florentlb,

I checked and i got an update this is not due to the upgrade.

Thank you,
Adithya