Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Getting Error while generating Access Token (ACS- API) in AEM

Avatar

Level 3

Hi Team,

I am trying to Test the transactional messaging via Adobe Campaign Standard through API call.

 

We have gone through the following references regarding usage of Adobe Campaign Standard APIs:

 

https://console.adobe.io/integrations

 

We checked it using POSTMAN. We are getting the below error. But using the Same JWT token we were able to generate access token earlier. We did not change anything in our code.

 

  • We have done the integration with ACS using Adobe I/O and have got the API Key (Client ID), Technical account ID, Technical account email, Organization ID, Client secret.
  • Using these values we generated a JWT Token (Java).
  • Further with the JWT Token, we were able to generate the values Access Token, Token Type, and expires_in(Java).

 

naveen123_0-1646414078031.png

naveen123_1-1646414164589.png

@fabios23415219 

@Senthil24 

@keremkulak 

@florentlb 

 

I have referred the below issue.

https://experienceleaguecommunities.adobe.com/t5/adobe-campaign-standard/getting-error-while-generat...

 

 

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

Hi there,

Did you get the JWT token from the Adobe I/O project itself? Did you get the postman environment from Adobe I/O project too? looks like the orgId used to generate the token doe snot have the correct structure.....as the error says, it must finish by @AdobeOrg

Thanks

Denis

View solution in original post

0 Replies

Avatar

Level 3

Hi All, 

Could you please help on this.


Regards

Naveen V

Avatar

Community Advisor

Hello @naveen123 

Looks like you are passing the payload in an incorrect way.

 

The client_id, client_sect, and jwt_token should be passed as body content but you have added them as parameters.

 

Refer to the below image.

 

Manoj_Kumar__0-1646489703158.png

 

 

Avatar

Level 3

HI Manoj, 

Thanks for replying on this.

 

naveen123_0-1646555044967.png

 

If I have the jwt token in jwt.io url then it is saying as invalid Signature. Could you please help on this how to resolve.

Avatar

Level 8

@naveen123 

 

Can you try generating a new public/private key pair for your integration and further generate a jwt and bearer token to see it this works?

Avatar

Correct answer by
Employee Advisor

Hi there,

Did you get the JWT token from the Adobe I/O project itself? Did you get the postman environment from Adobe I/O project too? looks like the orgId used to generate the token doe snot have the correct structure.....as the error says, it must finish by @AdobeOrg

Thanks

Denis

Avatar

Administrator

Hi @naveen123,

Were you able to resolve this query with the help of the given solutions or do you still need more help here? Do let us know. In case the given solutions were helpful, then kindly choose the one that helped you the most as the 'Correct Reply'.
Thanks!