Highlighted

Adobe campaign IIS integration cannot be installed

jitendrakhatwan

15-10-2018

Hi Team,

While installing Adobe Campaign Classic, I got this error message.
Error.png

IIS is running, i tried localhost and even Vm name, it's running.

IIS version 10.0.14393.0

Os : Windows Server 2016 Datacenter

Campaign Version : V7

This error appears when i click on iis_neolane_setup.vbs file to configure site.

I have tried giving full permissions to the folder and still it's the same.

Regards

Jitendra

Replies

Highlighted

andreal94243803

02-04-2019

Hi Jitendra,

Here is the solution if you still need it.

Search for cmd and run it as an admin.

SSL_certificate_1.0.PNG

Go to the directory of the VBS file.

iis-neolane-setup1.1.png

Run the file from the command line: Enter "iis-neolane_setup" and press Enter.

iis-neolane-setup1.2.png

A window will pop up and ask for confirmation. Click OK.

Enter the digit of the Website to configure (e.g. 1 or 2). Press OK.

Installation starts and will be completed in a few minutes.

I had the same error message and just installed successfully.

Highlighted

covertA

07-04-2019

The issue is with the VBS script it is designed on only work up IIS8. In order, to fix this issue you would need to statically set the iisVers to 10 and allow the installation to work correctly.

This will fix this error and allow the vbs script to install properly. Then do the following stated above.

Highlighted

ashishd57969090

16-04-2019

Is there any other solution to this issue. I'm facing the same issue and it still persist. Any pointer on this would really be helpful.

Highlighted

Jean-Serge_Biro

MVP

18-04-2019

Hi ashishd and Jitendra,

As said by covertA, the iis_neolane_setup.vbs file used for IIS integration must be changed for Windows 2016 server support and IIS 10 support.
It should be a factory/default script addendum, but in the meanwhile, duplicate   iis_neolane_setup.vbs  to  iis_neolane_setup2.vbs, edit the new file and add these 2 switch cases sections:

after line  597:

Case "10." GetOSVersion = 10    '= "IIS 10" Running on Windows server 2016

after line 624:

  Case 10

    call IIS7_install

(Sorry I don't know if I am allowed to send you the whole iis_neolane_setup2.vbs modified file, so I copied/pasted the 2 differents sections above).

Hope this helps.
Regards

J-Serge

Highlighted

ashishd57969090

18-04-2019

Thanks J-Serge for your reply. So you basically asking to call the IIS7_install script for windows 10 right. But it gives other errors. I tried the original script on windows 8 machine and it worked perfectly. I think adobe needs to provide new compatible script for IIS 10. I'm not sure if it is released or not. Do you see any other solution to this?

Highlighted

Jean-Serge_Biro

MVP

19-04-2019

Hi Ashishd,

If I understand you correctly, you don't have the same environment as Jitendra, because you are talking of Windows 8 and Windows 10, that are client machines, and Adobe Campaign is not compatible with Windows clients, only Windows servers OS.

Hi Jitendra,

Does the script modified satisfy your needs?

Regards
J-Serge

Highlighted

ashishd57969090

19-04-2019

thanks for your inputs J-Serge. I finally spinned up the new Windows server 2012 R2 instance and installed AC6 there. and the script for IIS 7 ran there successfully. Thanks!