Expand my Community achievements bar.

We are excited to introduce our latest innovation to enhance the Adobe Campaign user experience — the Adobe Campaign v8 Web User Interface!

SMPP SR issue

Avatar

Level 4

Hi Team,

 

we have configured SMPP external account with the provider and we are able to send sms's from Adobe Campaign Classic - > Campaign workflow, but unable to receive the SR / DLR from the provider any suggestions regarding the same?

 

Thanks in advance,

Shine v.v

 

 

10 Replies

Avatar

Employee Advisor

Enable detailed logs using 'Enable verbose SMPP traces in the log file' in the external account configuration.

 

Also, make sure you have configured SR regex in the SMS account: https://experienceleague.adobe.com/docs/campaign-classic/using/sending-messages/sending-messages-on-...

 

Thanks,

Wasil

Avatar

Level 4

Hi @wasil_z ,

 

Thank you for your response, Enable verbose SMPP traces in the log file is already enabled, what should i do next? and the vendor says that DLR's are pending please make a TRX connection, but Adobe Campaign Classic only supports TX and RX connection, the vendor says that the vendor also supports the TX and RX connection not sure where the issue is.

 

Thanks,

Shine v.v

Avatar

Employee Advisor

DLR/SR would be sent over RX connection. You're able to send messages which means TX connection is working as expected. Check with the vendor if there are any issues while sending Delivery Report(DLR/SR) to ACC(ESME) for Mobile originated (MO) Delivery Report(DLR/SR). Check ACC logs if the connections are being terminated(binding issues).

 

Thanks

Wasil

Avatar

Level 4

Hi @wasil_z , @david--garcia ,

 

when we check with the vendors, they say that that the Adobe Campaign is only establishing transmission connection / bind and not receiver connection / bind while connecting to the external accounts. Could you please help us out, on how the receiver connection / bind can be established from/ by Adobe Campaign Side.

 

Thanks,

Shine v.v

Avatar

Employee Advisor

Please check the connector you are using :

Wasil_Zafar__1-1664783915626.png

Maybe share your sms.log file entries. I am assuming you've selected 'Extended generic SMPP'.  There is a checkbox in Connection Settings 'Use different parameters for the receiver'. When this box is unchecked, the same settings are used for transmitter and receiver. When the box is checked, settings in the Connection settings section will apply to the transmitter and settings in the Receiver connection settings will apply to the receiver. Confirm with the vendor if they expect receiver connection on different sockets.

 

See: https://experienceleague.adobe.com/docs/campaign-classic/using/sending-messages/sending-messages-on-...

 

Feel free to raise a ticket with support, they could further assist in debugging the issue by analyzing backend logs/network capture.

 

HTH

 

Thanks

Wasil

Avatar

Community Advisor

You may need to configure the regex rules to parse the SR correctly, trace the SMPP packets during SR receive then validate the regex logic

 

David__Garcia_0-1663674314548.png

 

Avatar

Administrator

Hi @ShineVv0823,

Were you able to resolve this query with the help of the given solutions or do you still need more help here? Do let us know. In case the given solutions were helpful, then kindly choose the one that helped you the most as the 'Correct Reply'.
Thanks!



Sukrity Wadhwa

Avatar

Level 4

Hi @Sukrity_Wadhwa ,

 

Thank you for you message, we were not able to fix the issue, The SMS vendor says Adobe Campaign Classic is not establishing Receiver Bind. We are not sure what to do.

 

Thanks,

Shine v.v

Avatar

Community Advisor

Have you got the SMS process up and running?

You can check this from the Monitoring section of the Home page.

 

Thanks,

Deb

Avatar

Level 4

Hi @Deb_Tripathy ,

 

Thank you for your message, yes SMPP SMS External Account is set and and SMS's are getting sent, but the issue is Adobe is establishing the only the transmitter bind and not the receiver bind while connecting, the vendor says Adobe has to establish a transmitter bind to receive back the deliver SM, 

in the logs in Monitoring we can see, the transmission bind is getting established and the PDU's are getting sent, but no info on receiver bind.

 

Thanks,

Shine v.v