Expand my Community achievements bar.

Adobe Campaign User Groups are live now. Join our Adobe Campaign User Groups and connect with your local leaders!

Is the following a known bug or a new security setup under Adobe Campaign Classic?

Avatar

Level 2

We have upgraded our beta instance to 9368:

 

assiba_johnson_1-1706731133589.png

 

Today we tried to import a package of transactional emails template into the beta instance and got the following error:

 

assiba_johnson_2-1706731363158.png

We found the root cause which is the duplicate key as shown above.

The solution or workaround is to remove the FCPSeed data from the XML package before the import:

 

assiba_johnson_3-1706731853404.png

 

Is anyone can confirm if this is a bug or an expected behavior under the new build? 

 

Thanks in advance!

 

 

 

3 Replies

Avatar

Community Advisor

Hello @assiba_johnson 

 

This is not a bug.

 

internalName is unique for each record and you can have only one record for an internalName.

 

With this package, the Adobe campaign was trying to create a new record with the existing internalName and that is why you see this error.


     Manoj
     Find me on LinkedIn

Avatar

Level 1

Hi @_Manoj_Kumar_ ,

 

Please see my comment about the build version.

This is working fine under build 9356.

The error is related to the nmsseedmember_id. Of course related to the internalName.

Here is what we did:

 

- We exported a transactional email template as XML package from an ACC instance with build 9356 and tried to import it to an instance with build 9368 --> KO

 

-  We exported a transactional email template as XML package from an ACC instance with build 9356 and tried to import it to an instance with build 9356 --> OK

 

It seems that under the new build 9368, there is an extra check on the FCPSeed section in the XML while importating the transactional email template . So if already exists under the targeted instance, the package import fails. 

 

I also highlighted the workaround to fix it. Please review my first comment. Is this a bug or an expected behaviour under the new buiild?

 

Thanks in advance!

 

Avatar

Level 2

Hi @_Manoj_Kumar_ ,

 

You need to reproduce the case to understand what I am talking about here. Build 9356 not behaving the same way as Build 9368 while exporting and importing  transactional messages templates from Build from Build 9356 to 9368. 

But you can close this topic as we have the solution we mentioned earlier.

 

Thanks for help,

Assiba