Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Trouble deleting Algorithmic Model

seanm97690176
Level 1
Level 1

Hi All, 

 

Recently, my client ended their contract with one of their data providers. Over the last few weeks, I have been removing all data provide by this vendor. My question is, when trying to delete an Algorithmic model, has anyone ran into the error message {"message: Trait must be RULE-BASED or ONBOARDED", "code":"ILLEGAL_ARGUMENT"}? 

 

It's peculiar why I can't delete this model because 1) it hasn't had a successful run since 2017 2) their are no active traits using this model, and 3) there are no active segments using any traits (obviously). Meaning, I have no idea why this error is occurring. Please help. I need this model deleted, so I can delete the appropriate data sources, which will allow me to pass an upcoming audit. 

 

-Sean 

1 Accepted Solution
snielson
Correct answer by
Employee
Employee

Hi Sean,

 

I would recommend looking into your browser debugger (default usually F12), and view the network tab in the debugger when attempting to delete the model. The API call made to delete the model will return with a 500 error I believe, and should contain some more details on what else is linked, or preventing the model from being deleted.

 

Regards,

Shane

View solution in original post

6 Replies
snielson
Correct answer by
Employee
Employee

Hi Sean,

 

I would recommend looking into your browser debugger (default usually F12), and view the network tab in the debugger when attempting to delete the model. The API call made to delete the model will return with a 500 error I believe, and should contain some more details on what else is linked, or preventing the model from being deleted.

 

Regards,

Shane

View solution in original post

seanm97690176
Level 1
Level 1

Thanks Shane! Here's what I see: 

 

Models.ddx:4 DELETE https://bank.demdex.com/portal/api/v1/models/7958 net::ERR_NAME_NOT_RESOLVED
 nrWrapper@Models.ddx:4
 send@jquery-2.0.0.min.js:5
 ajax@jquery-2.0.0.min.js:5
 a.sync@backbone-0.9.2-build-min.js:1
 sync@bb_mvc.js?v=1167:2281
 destroy@backbone-0.9.2-build-min.js:1
 click@bundle.979f87f.min.js:43
 dispatch@jquery-2.0.0.min.js:4
 y.handle@jquery-2.0.0.min.js:4
 nrWrapper@Models.ddx:4

 

Does this help? 

 

 

If I wait a few seconds, the console then reports a ton of the same error...

 

<377> Unchecked runtime.lastError: The message port closed before a response was received.
Models.ddx:1 Unchecked runtime.lastError: The message port closed before a response was received.
Models.ddx:1 Unchecked runtime.lastError: The message port closed before a response was received.
Models.ddx:1 Unchecked runtime.lastError: The message port closed before a response was received.
Models.ddx:1 Unchecked runtime.lastError: The message port closed before a response was received.

snielson
Employee
Employee

Hey Sean,

 

I was hoping to see more.. but seems the message you provided initially was all there was? {"message: Trait must be RULE-BASED or ONBOARDED", "code":"ILLEGAL_ARGUMENT"}

However, your comment did provide the model ID so I checked on this myself and couldn't see what the issue was. I've opened a JIRA with our API team, and will provided an updated comment on what we find out.

 

Thanks,

Shane

seanm97690176
Level 1
Level 1
Thanks Shane! That's my understanding yes, this is all there was. Appreciate you making a jira ticket! Keep me posted.
snielson
Employee
Employee
@seanm97690176, turns out there is an issue with some checks on deleting a model that was tied to folder trait. This should be resolved in a future fix. In the meantime our API team manually removed this model for you.
seanm97690176
Level 1
Level 1
Thanks Shane! I was able to delete the data sources successfully. Have a great day! Thanks for your help.