Plugin update question on getTimeParting 3.4 > 6.2

DinoF40

26-03-2020

Hi,

 

I was hoping for some advice on updating the getTimeParting plugin from 3.4 > 6.2.

 

It appears the 3.4 code uses  "Utility Function: split v1.5 (JS 1.0 compatible)" which I don't believe is needed any more.

Also the older code needed to have the date ranges for time parting entered e.g.

 

//US
s._tpDST = {
2012:'3/11,11/4',
2013:'3/10,11/3',
2014:'3/9,11/2',
2015:'3/8,11/1',
2016:'3/13,11/6',
2017:'3/12,11/5',
2018:'3/11,11/4',
2019:'3/10,11/3',
2020:'3/8,11/1',

 

I assume with the new version of the code the above code is no longer necessary?

 

Cheers

Accepted Solutions (0)

Answers (2)

Answers (2)

ishans52004352

Employee

27-03-2020

Hi @DinoF40 ,

 

Your understanding is absolutely correct. The Utility function and the older code is no longer needed. With v6.2, the arguments to pass in contains an optional but recommended parameter t. It's the name of the time zone to convert the visitor's local time to. It defaults to "Etc/GMT", or "UTC/GMT" time. Common values are "Americas/New York" for Eastern time, "Americas/Chicago" for Central time, etc.

Example call: s.evar1 = getTimeParting ("Americas/New York");

 

 

PratheepArunRaj

Moderator

27-03-2020

Dear Dino,

Curious to know, did you validate the results? If no, try to do and share the results.

Thanks, Arun.