Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Launch Switch Connecting with Adobe Launch | Issue on Loading New Environments

Avatar

Level 2

Hi Everyone, 

 

Not sure if you have encountered this already but for the last days we are not able to connect the Adobe Launch with the Launch Switch. 

 

So before, to load the environments on launch switch we go to Adobe Launch >> Environments and then click the Launch Switch Extension. Now it's not loading. 

 

Below is the only one I see.

 

On the website: 

cheenee_deleon_1-1662603043786.png

 

On Adobe Launch  >> Environments

 

cheenee_deleon_0-1662602983215.png

 

We have also tried changing environments using Adobe Experience Debugger but for some reason it does not work on our website. It still gets the default Launch environment set for our UAT page which are used and not the environment we set it to use. 

 

Thanks everyone for your help. 

3 Replies

Avatar

Community Advisor

I've had on and off success switching the environment with the Launch Switch application.. once I got stuck in DEV environment and couldn't get back until I uninstalled and reinstalled...

 

I use a different method... I have a add on called Resource Override, where I can just add URL to URL rules:

 

Jennifer_Dungan_0-1662611605675.png

 

Jennifer_Dungan_1-1662611630167.png

 

 

I can set up multiple overrides and turn them on/off at will.

 

I find this tool a little more reliable, as it doesn't actually have to connect into the code or find the correct environment, it simple creates a redirect for any file on the site (as soon as the request is made), and since I know exactly the file locations (from the environments area in launch), I can easily set these up.

 

IF you have multiple sites, you might want to modify the URL from * to site specific.. but to make sure it loads on every page, use https://www.domain.com/*

 

You can turn on and off entire rule sets by domain... or at each file...

 

I still use Launch Switch to get the debug logs in my console, I just don't use its environment switch behaviour... the two tools work together fine for me (and with the cloud debugger - I use the three together frequently). You just have to make sure that you set up your overrides correctly.

 

Sorry I can't help more with your current issue, and suggesting a third add-on... but it might work better for you, especially if you are having issues....

 

Good Luck!

Update: I should have posted a link to the Resource Override Extension: https://chrome.google.com/webstore/detail/resource-override/pkoacgokdfckfpndoffpifphamojphii

Avatar

Level 2

Thanks for the reply. Will give this one a try.

 

Currently I was able to use Redirector Chrome extension which redirects my scripts to resource from what currently is set on the website to which environment I want to use. I have also used Charles Proxy Server using re-map. 

Avatar

Community Advisor

I have other extensions that stopped to work and do not allow to overwrite libraries anymore as well. I just gave up and started to use the official Adobe Experience Platform extension https://chrome.google.com/webstore/detail/adobe-experience-platform/bfnnokhpnncpkdmbokanobigaccjkpob...