Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

REPORT SENDING: While sending report it does not filter as used from Prompt, it sends all info to the user??

Avatar

Level 9

Hi

While sending report it does not filter as used from Prompt, it sends all info to the user??

Even after prompt usage, and sending after also send all the data.

Any tips to stop such list.

Best regards,

Kundan

8 Replies

Avatar

Level 10

Hi Kundan,

As far as I am aware, you are not able to use prompts when sending reports directly from Workfront. Since prompts are effectively filters that are configured 'on the fly' by a user, they are lost when you go to send the report because Workfront re-generates the report from scratch (losing your prompt settings) when you go to send it.

In order to over come this, you will either need to:

  1. Make a copy of the report, configure your prompt criteria as a filter rule in the report configuration and then send the report
  2. Apply your desired prompts to the report and manually export / send the report.

Best Regards,

Rich.

Avatar

Level 10

Ah jeez, and I just promised I could do this…

So I couldn't set up a "Send" for a report without getting past the prompt. So I assumed it saved that prompt answer as part of the send.

It doesn't?

Avatar

Level 9

Yes, it does not @Kevin Quosig‚

I don't know but this are the basic things required while using such options. Believe in coming future Workfront can see these basic and must type potentials and implement soon.

Mvh

Kundan

Avatar

Level 9

HI @Richard Leek‚

Thank you, I absolutely agree with you, but as a whole we miss this functionality which is required.

Have a nice day!

Mvh

Kundan.

Avatar

Level 10

So the workaround I assume is to duplicate the report and hard-wire the filter so no prompt is needed?

Can I assume $$USED.ID and $TODAY and things like that still work, as long as they are a filter and not a prompt?

Avatar

Level 10

Hi Kevin,

Yes, the workaround would be to duplicate the report and hard code the prompt criteria as filter rules.

User based wildcards don't work as you would expect. When you set up the report send, you specify the user that you want the report to be delivered with the access rights of (which is defaulted to the person that set up the report send). So if the report had an 'Assigned to = $$USER.ID' filter rule set up, the report would show all tasks assigned to you if you were the person who set up the report send. For this reason, you will need to remove the $$USER.ID wildcard from the filter rules and hardcode the desired user name into the filter rules before sending the report.

Date based wildcards aren't affected by report sends and will continue to behave as you expect.

Best Regards,

RIch.

Avatar

Level 10

So I'd have to generate a copy of the report, one for each user who needed the automated send?

The plan was to send this report to a number of team leads and have it focus on themselves and their team…

Avatar

Level 10

Yes, you would need a copy of the report for each recipient with their repective team's / user names hard coded as filter rules.