Expand my Community achievements bar.

Join us for our Coffee Break Sweepstakes on July 16th! Come ask your questions or share your use cases on Creative Briefs for a chance to win a piece of Workfront swag!
SOLVED

Creating Expenses

Avatar

Level 3

"I'm trying to create a new expense in Adobe Workfront Fusion, but I keep encountering an error message saying '[422] expenseID cannot be null'. I was under the impression that the system would automatically generate the expense ID, so I'm not sure why I'm receiving this error. Can you please guide me through creating a new expense and help me understand why I might be experiencing this issue?"

The logic is if the expense description is XYZ do something so a router that goes up ( one path), if not create an expense line with the description, year, and some amount. This can be seen in the attached screenshot below. 

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

Expense ObjCode should be PROJ, and not EXPNS if you are creating this on a project.

Let me know if this resolves the issue

View solution in original post

4 Replies

Avatar

Community Advisor

hi,

you're correct. When using "create record" module Fusion will assign ID to the created object. The only required fields for Expense object type to be created are: objID, expense objCode and e.g. taskID if you are creating that expense on a task, it will be projectID if expense is created on a project.

Rafal_Bainie_0-1704291203376.png

 

i didn't had any issue creating expense this way

Avatar

Level 3

Hey @Rafal_Bainie ,

I have attached a view for your reference, I would like to add an expense line with certain values mapped under cost as you see in the screenshot. I have also attached how I achieved the same using fusion, but unfortunately, it does not create an expense as there is no ID in the Output of the create expense module. 

Avatar

Correct answer by
Community Advisor

Expense ObjCode should be PROJ, and not EXPNS if you are creating this on a project.

Let me know if this resolves the issue

Avatar

Level 3

@Rafal_Bainie Thanks for your quick response, it works now! Thanks a lot