Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

salvadorm142499
salvadorm142499
Offline

Badges

Badges
12

Accepted Solutions

Accepted Solutions
0

Likes Received

Likes Received
3

Posts

Posts
36

Discussions

Discussions
4

Questions

Questions
32

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by salvadorm142499
Customize the badges you want to showcase on your profile
Re: Integration testing with WCM IO - AemContext - Adobe Experience Manager 01-03-2017
Hi Daniel,It helps a lot to resolve the previous issue and now, I can use AemContext Object. However, I am facing the next issue: Running wcm.salvaITest.PageTest Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.398 sec <<< FAILURE! - in wcm.salvaITest.PageTest testSomething(wcm.salvaITest.PageTest) Time elapsed: 0.322 sec <<< ERROR! java.lang.NoClassDefFoundError: org/apache/sling/models/factory/ModelFactoryAll I have done so far is:Generate AEM project by using Eclipse plugin a...

Views

1.7K

Likes

0

Replies

0
Integration testing with WCM IO - AemContext - Adobe Experience Manager 24-02-2017
Hi all,I am trying to write Junit test by using WCM IO testing tools. I have been reading lots of articles but I can't make it work. The steps I follow are:Add maven dependency for AEM 6.2 io.wcm io.wcm.testing.aem-mock 2.2.0 Add test case within the core bundlepackage com.my.project.core.models; import org.apache.sling.api.resource.ResourceResolver; import org.junit.Rule; import org.junit.Test; import io.wcm.testing.mock.aem.junit.AemContext; public class MyFirstITest { @Rule public final AemC...

Views

5.6K

Like

1

Replies

7
TagManager doesn't find components tagged - Adobe Experience Manager 03-01-2017
Hi all,I would like to tag components trough the cq:tags property in order to search for them quickly. However, the TagManager -> tagManager.find(tag.getTagID(); can't find them.I believe it is related with the cq:Taggable mixin. Could it be applied to a cq:Component node type? Regards,Salvador,

Views

754

Likes

0

Replies

2
Re: AEM 6.2 & Hybris 5.7 - OSGi Dependency error - Adobe Experience Manager 07-10-2016
After installing the cq-hybris-content-6.2.100.zip package, AEM 6.2 uses the following maven dependency: com.adobe.cq.commerce cq-commerce-hybris-impl 6.1.2 providedThis version is not found on the Adobe Public Repository. Could it be the reason why there is a mismatch between OSGi dependencies?

Views

1.6K

Likes

0

Replies

3
AEM 6.2 & Hybris 5.7 - OSGi Dependency error - Adobe Experience Manager 06-10-2016
Hi all,I would like to connect to Hybris 5.7 from my AEM 6.2 instance. To do so, I have installed the package 'cq-hybris-content-6.2.100' as per documentation (https://docs.adobe.com/docs/en/aem/6-2/deploy/ecommerce/hybris.html) and I am able to import products from Hybris to AEM.Secondly, I have added the following maven dependency (latest version from adobe public repo) in order to use 'DefaultHybrisService' from the package 'com.adobe.cq.commerce.hybris.common' to connecto to Hybris and devel...

Views

1.8K

Likes

0

Replies

5
Re: Maven dependency for uber-jar does not find its version - Adobe Experience Manager 16-09-2016
Hi Feike,The core bundle from 'Las Vegas' project isn't active into the OSGi Container due to: javax.inject,version=[0.0,1) -- Cannot be resolved. This is a knwon issue and all you need to do is to include this dependency: org.apache.geronimo.specs geronimo-atinject_1.0_spec 1.0 provided Then, add it to the core module as the first dependency and the bundle will be active --> javax.inject,version=1.0.0 from org.apache.geronimo.specs.geronimo-atinject_1.0_spec (294)I hope it helps other people.C...

Views

2.9K

Like

1

Replies

0
Re: Maven dependency for uber-jar does not find its version - Adobe Experience Manager 16-09-2016
smacdonald2008 wrote... Yup - i can reproduce this issue - please file a ticket as per Kautuk's suggestion. This is not working the way it should. Hi smacdonald,All we needed is to specify the classifier on the dependency section of the child modules.Regards,Salvador.

Views

2.9K

Likes

0

Replies

0
Re: Maven dependency for uber-jar does not find its version - Adobe Experience Manager 16-09-2016
Hi Feike,Thanks for this suggestion. I found the issue by looking at 'Las Vegas' project. The issue was I did not specify the classifier on the child modules.Thanks for your support,Salva.

Views

3.1K

Likes

0

Replies

0
Re: Maven dependency for uber-jar does not find its version - Adobe Experience Manager 15-09-2016
Sure! 🙂 It is already within the archetype.

Views

2.9K

Likes

0

Replies

0
Maven dependency for uber-jar does not find its version - Adobe Experience Manager 15-09-2016
Hi all,I have created a new project by using Eclipse+AEM Plugin for AEM 6.2 based on a multi-module project whose archetype is: aem project archetype 10.Then, I have removed this dependency: com.adobe.aem aem-api 6.0.0.1 provided And, following the link https://docs.adobe.com/docs/en/aem/6-2/develop/dev-tools/ht-projects-maven.html, I have added this: com.adobe.aem uber-jar 6.2.0 apis provided After building my project, I get this error:[ERROR] Some problems were encountered while processing t...

Views

6.1K

Like

1

Replies

12
Likes from