Expand my Community achievements bar.

Radically easy to access on brand approved content for distribution and omnichannel performant delivery. AEM Assets Content Hub and Dynamic Media with OpenAPI capabilities is now GA.
SOLVED

Maven dependency for uber-jar does not find its version

Avatar

Level 3

Hi all,

I have created a new project by using Eclipse+AEM Plugin for AEM 6.2 based on a multi-module project whose archetype is: aem project archetype 10.

Then, I have removed this dependency:

            <dependency>
                <groupId>com.adobe.aem</groupId>
                <artifactId>aem-api</artifactId>
                <version>6.0.0.1</version>
                <scope>provided</scope>
            </dependency>

And, following the link https://docs.adobe.com/docs/en/aem/6-2/develop/dev-tools/ht-projects-maven.html, I have added this:

    
<dependency>
    <groupId>com.adobe.aem</groupId>
    <artifactId>uber-jar</artifactId>
    <version>6.2.0</version>
    <classifier>apis</classifier>
    <scope>provided</scope>
</dependency>

 

After building my project, I get this error:

[ERROR] Some problems were encountered while processing the POMs:

[ERROR] 'dependencies.dependency.version' for com.adobe.aem:uber-jar:jar is missing. @ com.myproject:aem-bundle-core:[unknown-version]

 

Does anybody know what I am missing?

 

Thanks, Salvador.

1 Accepted Solution

Avatar

Correct answer by
Employee

Can you checkout/clone this git project, that is working and should bring you further:

git: git clone https://github.com/heervisscher/l318.git

cd l318/lasvegas

maven: mvn clean install -s settings.xml -U

View solution in original post

12 Replies

Avatar

Level 3

Sure! :) It is already within the archetype.

Avatar

Level 10

I will try this too - i have used 6.1 as 6.2 was causing issue. I will post back my findings. 

Avatar

Level 10

Yup - i can reproduce this issue - please file a ticket as per Kautuk's suggestion. This is not working the way it should. 

Avatar

Correct answer by
Employee

Can you checkout/clone this git project, that is working and should bring you further:

git: git clone https://github.com/heervisscher/l318.git

cd l318/lasvegas

maven: mvn clean install -s settings.xml -U

Avatar

Level 3

Hi Feike,

Thanks for this suggestion. I found the issue by looking at 'Las Vegas' project. The issue was I did not specify the classifier on the child modules.

Thanks for your support,

Salva.

Avatar

Level 3

smacdonald2008 wrote...

Yup - i can reproduce this issue - please file a ticket as per Kautuk's suggestion. This is not working the way it should. 

 

Hi smacdonald,

All we needed is to specify the classifier on the dependency section of the child modules.

Regards,

Salvador.

Avatar

Level 3

Hi Feike,

The core bundle from 'Las Vegas' project isn't active into the OSGi Container due to: javax.inject,version=[0.0,1) -- Cannot be resolved. This is a knwon issue and all you need to do is to include this dependency:

            <dependency>
                <groupId>org.apache.geronimo.specs</groupId>
                <artifactId>geronimo-atinject_1.0_spec</artifactId>
                <version>1.0</version>
                <scope>provided</scope>
            </dependency>

Then, add it to the core module as the first dependency and the bundle will be active --> javax.inject,version=1.0.0 from org.apache.geronimo.specs.geronimo-atinject_1.0_spec (294)

I hope it helps other people.

Cheers,

Salvador.

Avatar

Administrator

Hi Salvador, 

Thank you, this would surly help the community.

~kautuk



Kautuk Sahni

Avatar

Employee

You can also check the "result" or "aem6.2" branch.

Avatar

Level 4

Hi,

I am trying to add uber 6.3.2.2, but it says missing dependency. But when i add "<classifier>obfuscated-apis</classifier>", it works fine

Can you please tell me why this classifier is required? Will it be a problem for me later?