since ‎30-07-2009
‎10-12-2019
Rob_Curran__T4G
Level 2
event.job.topic indexing AEM 6.2 Rob_Curran__T4G - Adobe Experience Manager
A question about AEM performance, particularly workflow related activities, including usability of the Workflow Admin interface.AEM 6.2 seems to disable by default the event.job.topic property index (/oak:index/event.job.topic). The intent SEEMS to be to replace this with the slingeventJob (/oak:index/slingeventJob) index.However, as the volume of workflow data grows in a high volume environment the slingeventJob index under performs the old property index by an order of magnitude. Cost of the p...
927
Views
1
Like
0
Replies
SQL2 - Query for nodes without specific child node Rob_Curran__T4G - Adobe Experience Manager
AEM 6.2...I would like to identify nodes in the DAM which may have been missed by a disabled DAM Update Asset workflow. These nodes would be missing a child metadata and/or renditions.Executing the following two queries returns identical results:1) SELECT * FROM [dam:Asset] AS s WHERE ISDESCENDANTNODE([/content/dam/])2) SELECT * FROM [dam:Asset] AS s WHERE ISDESCENDANTNODE([/content/dam/]) and [jcr:content/metadata] is nullThe null check does not appear to be respected.The following query return...
1547
Views
1
Like
0
Replies
Search Paging Performance Rob_Curran__T4G - Adobe Experience Manager
We have an AEM 6.1 SP1 sites deployment where we are seeing exceptionally poor search performance using the OOTB /libs/foundation/components/search component.The initial search is slow against a very small hierarchy of pages. It returns less than 20 results (in one example) which is paged 10/page. When navigating / paging back and forth between page 1 and 2 of the results we see significant spikes in CPU usage from 5% up to over 150%. Additionally, memory usage seems to climb slightly with each ...
1183
Views
0
Likes
3
Replies
Re: AEM SOLR Log Message Rob_Curran__T4G - Adobe Experience Manager
Just curious if you found a resolution to these messages in the log. Seeing the same with an AEM 6.2 environment upgraded from AEM 6.1 with Solr.Thanks.
497
Views
0
Likes
0
Answers
Re: .DS_Store files created in Repository when connecting via WebDAV from a MAC Rob_Curran__T4G - Adobe Experience Manager Assets
I did also find this thread: http://stackoverflow.com/questions/33129042/how-to-hide-hidden-files-in-aem-crxde-liteWhich suggests using an OSGi scheduler to simply delete them regularly from AEM.package com.foo.bar; import org.apache.felix.scr.annotations.sling.SlingServlet; import org.apache.sling.api.SlingHttpServletRequest; import org.apache.sling.api.SlingHttpServletResponse; import org.apache.sling.api.resource.Resource; import org.apache.sling.api.resource.ResourceResolver; import org.apac...
832
Views
0
Likes
0
Answers
Re: .DS_Store files created in Repository when connecting via WebDAV from a MAC Rob_Curran__T4G - Adobe Experience Manager Assets
Thanks Mark.This looks promising if the users are willing to make this configuration change. I don't have a MAC to test on either... Your response is appreciated.
845
Views
0
Likes
0
Answers
Re: Offloading Documentation Truncated Rob_Curran__T4G - Adobe Experience Manager Assets
Thanks!
775
Views
0
Likes
0
Answers
.DS_Store files created in Repository when connecting via WebDAV from a MAC Rob_Curran__T4G - Adobe Experience Manager Assets
These files get created at each level in the repository when a user creates content (uploads files) via WebDAV to the DAM. There are actually two files I think... .DS_Store and _.DS_Store...Is there a way to avoid this / correct it?Thanks, Rob.
2072
Views
0
Likes
4
Answers and Comments
Offloading Documentation Truncated Rob_Curran__T4G - Adobe Experience Manager Assets
Does anyone from Adobe know why the Offloading documentation is truncated?https://docs.adobe.com/docs/en/aem/6-2/deploy/configuring/offloading.html Any chance of getting it fixed? Thanks,Rob.
1107
Views
0
Likes
3
Answers and Comments
Re: Hosting Static HTML in the JCR Rob_Curran__T4G - Adobe Experience Manager
Thanks very much for this helpful response. I have confirmed this re-enables this functionality on my environment.In my particular case I want to serve these files as an interim step in a migration effort so I am not concerned about the security concerns. I will recheck the box once completed.Cheers.
1662
Views
0
Likes
0
Answers
Re: Hosting Static HTML in the JCR Rob_Curran__T4G - Adobe Experience Manager
I have the same issue. I have a package containing static HTML files.I import this into AEM 6.1 and it is rendered to the browser.Importing the exact same package into AEM 6.2 results in the files being downloaded instead of served into the browser.I attempted to add /content/path and also /content/path/somefile.html to the Apache Sling Content Disposition Filter as suggested without seeing any difference in behavior.I'm curious if you had made any other changes to get this working. Thanks.
1633
Views
0
Likes
0
Answers
Re: AEM 6.1 Upgrade - Missing Tags after upgrade Rob_Curran__T4G - Adobe Experience Manager
Was this resolved? I have the same behavior after upgrading 6.0 to 6.1 and applying SP1. The /etc/tags folder is missing.
862
Views
0
Likes
0
Replies
Re: Sightly Component Failure after AEM 6.0 -> 6.2 upgrade Rob_Curran__T4G - Adobe Experience Manager
Thanks for the response.I had already corrected dependency issues, replaced deprecated WCMUse class, etc. That all went well.The issue was finally resolved after root cause was traced to TooManyCallsExceptions...The TooManyCallsException is thrown by the Sling implementation if too many inclusions have been called for during a single request.This setting can be configured from the Sling Main Servlet configuration under Felix console. http://:/system/console/configMgr/org.apache.sling.engine.impl...
774
Views
0
Likes
0
Answers
Sightly Component Failure after AEM 6.0 -> 6.2 upgrade Rob_Curran__T4G - Adobe Experience Manager
We are experiencing issues with Sightly components in a custom solution after upgrading to AEM 6.2. We can reproduce the issue on a clean AEM 6.2 server (not upgraded). Unfortunately there are no error messages so we do not have much to go on... I am describing here in case someone has encountered this previously and has some tips to resolve or debug.I'll describe the non-upgraded path to reproduce...We installed AEM 6.2 quickstart (author). Then deployed the we.retail sample package. Everything...
1087
Views
0
Likes
3
Answers and Comments
Fluctuating Performance after upgrade from AEM 6.1 to 6.2 Rob_Curran__T4G - Adobe Experience Manager
We have an environment which was recently upgraded from AEM 6.1 to 6.2. Intermittently for periods of 15mins to an hour the server becomes nearly unresponsive. During these periods there are no errors in the logs.However, I've noticed warnings related to idle sessions popping up every 20-30 seconds which seems excessive. Is this related? Any other thoughts?28.06.2016 15:33:40.203 *INFO* [10.240.1.3 [1467141961252] GET /mnt/overlay/granite/ui/content/shell/header/actions/pulse.data.json HTTP/1.1]...
6479
Views
1
Like
8
Replies
Re: Touch UI version of Custom Asset Share Page Rob_Curran__T4G - Adobe Experience Manager Assets
Thanks for the response. I'm aware of the brand portal... however this is a SAAS offering in the Cloud. I'm looking for a solution which can be hosted in the AEM publish instance.
1056
Views
0
Likes
0
Answers
Touch UI version of Custom Asset Share Page Rob_Curran__T4G - Adobe Experience Manager Assets
Is there a strait forward way to securely expose the /assets page on a publish instance effectively creation a TouchUI version of an Asset Share Page?The Asset Share Page documentation outlines an approach using the classic UI which is not desirable. https://docs.adobe.com/docs/en/aem/6-2/author/assets/using-asset-share-pages.htmlEssentially, I'd like to expose an anonymous Asset search page on the publish instance which mirrors the functionality of the /assets page (filter, full text search, et...
1611
Views
0
Likes
4
Answers and Comments
Special Characters in JSON cause failure in custom MetadataSchema Form Rob_Curran__T4G - Adobe Experience Manager Assets
Can someone confirm if this is a defect or a work-around for the following special characters issue?Created a new MetadataSchema and added a Dropdown object when building the form.The issue is that if you source the values for the drop-down from a JSON object (set the JSON Path in the field settings) then if the JSON contains certain special characters it causes the form to fail.If the JSON source contains a slash (/) or a colon (:) in the text property then the slash causes it to create corrupt...
2043
Views
1
Like
3
Replies
Custom Search Form - Options Predicate with JSON Source Fails - AEM 6.2 Rob_Curran__T4G - Adobe Experience Manager Assets
Customizing the "Assets Admin Search Rail" search form.Adding a new options predicate with a "JSON Path" source results in a filter that doesn't work.Specifically, add an "Options Predicate" and configure the following settings:Field Label - whateverJSON Path - Path to json object in repo (eg. /apps/appname/rights.txt) which as the following content:// Rights Management{"options": [ { "value": "royalty_free", "text": "Royalty Free" }, { "value": "rights_managed", "text": "Rights Managed" }, { "v...
3175
Views
0
Likes
3
Answers and Comments
Re: Custom Search Form for DAM content path Rob_Curran__T4G - Adobe Experience Manager Assets
Thanks for the response / confirmation.Is the implementation for Metadata Schemas something you are familiar with? Just wondering if you can save me some reverse engineering... what components / code should I be looking at to implement this custom functionality?Any idea on level of effort?We had already configured the custom metadata schema for our specific folder in the DAM.Seems like something that should be available OOTB, especially in multi-tenant scenarios where different groups with vastl...
1036
Views
0
Likes
0
Answers
Custom Search Form for DAM content path Rob_Curran__T4G - Adobe Experience Manager Assets
When you customize the "Assets Admin Search Rail" search forum the changes you make (adding predicates for example) are visible in all contexts in Assets.https://docs.adobe.com/docs/en/aem/6-2/administer/operations/search-forms.htmlIs there any way to have the custom predicates only show for specific paths in the content tree? Eg. not visible in /content/dam/abc but visible in /content/dam/defThanks.
1624
Views
0
Likes
3
Answers and Comments
Re: AEM 6.2 - Unable to access Custom Search Form Rob_Curran__T4G - Adobe Experience Manager
Thanks for relocating to AEM forum... it was accidentally posted to wrong topic.
680
Views
0
Likes
0
Answers
AEM 6.2 - Unable to access Custom Search Form Rob_Curran__T4G - Adobe Experience Manager
Following documentation to add a custom search form (in my case for Asset Admin Search Rail) I can create a custom configuration for a search form. However, when it says to navigate to the "Search Panel" it is no longer possible in 6.2 to access this panel.Configuring Search FormsHow do you access the custom search form / search panel in the AEM 6.2 Touch UI? Thanks for any help. Rob
868
Views
0
Likes
2
Answers and Comments
Re: csrf enabled but empty through /libs/granite/csrf/token.json Rob_Curran__T4G - Adobe Experience Manager
Thanks Opkar.I had just done some more reading and came to the same conclusion. I was just about to answer my own question.Thanks again for your reply.Rob.
7640
Views
0
Likes
1
Replies
Re: csrf enabled but empty through /libs/granite/csrf/token.json Rob_Curran__T4G - Adobe Experience Manager
Jason, Did you resolve your first issue?I have a situation where the csrf token is empty ("{}") when I make an unauthenticated call to /libs/granite/csrf/token.json. However, when making an authenticated call I receive a token as expected: {"token":"ey....U0"} Thanks, Rob.
7640
Views
0
Likes
6
Replies
NoSuchNodeTypeException after restart Rob_Curran__T4G - Adobe Experience Manager
Looking for root cause of NoSuchNodeTypeExceptions which are preventing AEM instances (two of them on the same server... Author/Publish) from starting successfully.The exact pathology is a but unclear at this point. The servers were shutdown, compaction was executed and failed. Then when restarted these errors showed up and AEM was not healthy.However, after restoring a backup from when the AEM instance was healthy the same error occurs. And now the same shows up on the Publish instance on the s...
1177
Views
0
Likes
2
Replies
Re: Viewing Workflow Pages through Dispatcher Fails - No component node found at /bin/wcmcommand.servlet Rob_Curran__T4G - Adobe Experience Manager
More thoughts...I'm thinking this is actually related to the old version of Apache (2.2.15) which is installed.I'm basing this on a thread here: http://stackoverflow.com/questions/4390436/need-to-allow-encoded-slashes-on-apacheNot sure if I need to just get Apache updated (I don't completely control environment) or if I can just add some flavor of the following directive...AllowEncodedSlashes NoDecodeAgain, input is welcome. Thanks.
3364
Views
0
Likes
1
Replies
Re: Viewing Workflow Pages through Dispatcher Fails - No component node found at /bin/wcmcommand.servlet Rob_Curran__T4G - Adobe Experience Manager
On working Windows Dispatcher that line looks like this:10.11.19.54 - - [12/Apr/2016:22:42:03 -0400] "GET /bin/wcmcommand?cmd=open&path=%2Fcontent%2Fcountry-sites%2Fu%2Fen&_charset_=utf-8 HTTP/1.1" 302 -I can see the difference.... %2F vs %252F... but what is the cause / resolution?
3364
Views
0
Likes
2
Replies
Re: Viewing Workflow Pages through Dispatcher Fails - No component node found at /bin/wcmcommand.servlet Rob_Curran__T4G - Adobe Experience Manager
Additional Background:The offending environment:RedHatDispatcher 4.1.12Apache 2.2.15JDK 1.8_31 Attempted to reproduce on:WindowsDispatcher 4.1.12Apache 2.2.25JDK 1.8_71After copying the exact dispatcher configuration to a Windows platform and pointing to the same AEM Author Instance (6.1 SP1 on Redhat) I was unable to reproduce.Is the issue perhaps with the Dispatcher 4.1.12 on RedHat specifically?
3364
Views
0
Likes
5
Replies
Re: Viewing Workflow Pages through Dispatcher Fails - No component node found at /bin/wcmcommand.servlet Rob_Curran__T4G - Adobe Experience Manager
Thanks for the reply.The setup is a standard Author Dispatcher /filter with allow all then deny filters. I believe /bin is permitted with this filter. Additionally, the fact that the error mentioned is showing in the AEM log would suggest it is getting through the Dispatcher./filter { # allow everything /0001 { /type "allow" /glob "*" } # block admin tools /0010 { /type "deny" /glob "* /admin/*" } /0011 { /type "deny" /glob "* /admin *" } /0012 { /type "deny" /glob "* /system/*" } /0013 { /type ...
3364
Views
0
Likes
6
Replies