Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

bhavani_ikkurth
bhavani_ikkurth
Offline

Badges

Badges
6

Accepted Solutions

Accepted Solutions
0

Likes

Likes
0

Posts

Posts
12

Discussions

Discussions
0

Questions

Questions
12

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by bhavani_ikkurth
Customize the badges you want to showcase on your profile
Re: ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
justin_at_adobe wrote...bhavani IKKURTHI wrote...justin_at_adobe wrote...The problem doesn't have anything to do with this class. It has to do with how you are accessing this class or really the instance. You are creating a new instance of this class. Instead, you should use the instance created by DS.You should not use getServiceReference() in a DS component except for very specific needs (which this is definitely not an example of). Well, if I access the DS instance of the class using @Referen...

Views

193

Likes

0

Replies

0
Re: ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
justin_at_adobe wrote...The problem doesn't have anything to do with this class. It has to do with how you are accessing this class or really the instance. You are creating a new instance of this class. Instead, you should use the instance created by DS.You should not use getServiceReference() in a DS component except for very specific needs (which this is definitely not an example of). Well, if I access the DS instance of the class using @Reference annotation it returns null.

Views

198

Likes

0

Replies

0
Re: ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
protected void activate(ComponentContext context) { BundleContext bundleContext = context.getBundleContext(); ServiceReference serviceReference = bundleContext.getServiceReference(ConfigurationManager.class.getName( )); ConfigurationManager cfgMgr = (ConfigurationManager) bundleContext.getService(serviceReference); } In the above code also, I get cfgMgr as null. Sham, Can you please share the code that you have tested with?

Views

198

Likes

0

Replies

0
Re: ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
Do I have to add the package cq-wcm-webservice-support as an exclusive dependency to the maven pom.xml? Can you please provide me a code snippet to retrieve the service from BundleContext?

Views

197

Likes

0

Replies

0
Re: ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
Sham HC wrote...It is not a bug & I can'ot reproduce the issue. Which version of AEM? Are you seeing the configuration manager in your instance at http://localhost:4502/system/console/servicesOtherway of getting is using bundlecontext getService method. I am on CQ 5.5 I can see the service. [img]Screen Shot 2013-10-10 at 3.38.46 PM.png[/img]

Views

197

Likes

0

Replies

0
Re: ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
smacdonald2008 wrote...That is a possibility - when you inject a ConfigurationManager - it should not be null. Sham - do you think a ticket should be opened? So, is there another way of getting the ConfigurationManager without using Reference annotation? Please advise.

Views

195

Likes

0

Replies

0
Re: ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
I am sure cfgMgr is null. I added a null check statement to find it out and it came out as null. Do you think I ran into any kind of bug here?

Views

197

Likes

0

Replies

0
ConfigurationManager Reference is null
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
import com.day.cq.wcm.webservicesupport.Configuration; import com.day.cq.wcm.webservicesupport.ConfigurationManager; @Component(immediate=true) public class Videos { private final Logger log = Logger.getLogger(Videos.class); private Configuration configuration; @Reference private ConfigurationManager cfgMgr; public void connectToService() { configuration = cfgMgr.getConfiguration("mycustomservice"); } } cfgMgr is null. I wonder why is a reference variable null anyway. Are there any other methods...

Views

869

Likes

0

Replies

13
Re: Bundle not starting - CQ5
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
I do not see a version number in my POM.xml's here. Do you know what artifact that I have to look up?

Views

140

Likes

0

Replies

0
Bundle not starting - CQ5
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
The status of the bundle in felix console reads as installed. If I try to start it, it wont. I see an error in red when I expand the bundle. I have other bundles started and running without issues. I use maven to build and deploy. Appreciate your help!org.osgi.framework,version=[1.7,2) -- Cannot be resolved

Views

202

Likes

0

Replies

5
Re: Link Checker Transformer not stripping html for JavaScript load
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
I have edited my question. There is no anchor tag now. It is a list element. I want to have clean URL's without any .html extensions.

Views

195

Likes

0

Replies

0
Link Checker Transformer not stripping html for JavaScript load
Avatar
Ignite 3
Level 2
bhavani_ikkurth
Level 2

Likes

0 likes

Total Posts

12 posts

Correct reply

0 solutions
Top badges earned
Ignite 3
Give Back 5
Give Back 3
Give Back
Ignite 1
View profile
bhavani_ikkurth
- Adobe Experience Manager
I have the Link Checker Transformer service turned on and the strip html extension option checked in the felix console. It is working as intended except in the following scenario.I have an unordered list on a page:Click HereOn clicking "Click Here", an event is triggered that redirects to another URL: /content/mysite/testpage.html using jQuery(location).attr('href', "/content/mysite/testpage.html");In this case, the .html is still dangling around in the URL even after testpage has loaded.PS: rem...

Views

515

Likes

0

Replies

3
Likes given to