Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

DNest19
DNest19
Online

Badges

Badges
12

Accepted Solutions

Accepted Solutions
0

Likes

Likes
10

Posts

Posts
15

Discussions

Discussions
11

Questions

Questions
2

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by DNest19
Customize the badges you want to showcase on your profile
Unable to Inject htl parameters on publish instance - Adobe Experience Manager 13-05-2022
I am converting WCMusePojos to sling models and have run across an issue that I have been unable to resolve. For some reason the parameters from my HTL isn't being injected on the publish instance. This works fine on the author instance, but both variables are null on publish when I check the logs. What could be causing this issue? Here's the model: package com.my.aem.dam.core.portal; import com.day.cq.wcm.api.components.ComponentContext; import org.apache.sling.api.SlingHttpServletRequest; impo...

Views

93

Likes

0

Replies

3
Re: OSGI config edited in repo not applying during runtime - Adobe Experience Manager 07-03-2022
I tried this fix and it's still not getting picked up until I hit save all manually.

Views

180

Like

1

Replies

2
Re: OSGI config edited in repo not applying during runtime - Adobe Experience Manager 04-03-2022
Edited my response. I though this had solved the issue, but I still have to hit save all in the repo to get the changes to pick up. Is there a way to perform that action programmatically? I thought session.save() is more or less equivalent, but it doesn't seem to be.

Views

224

Like

1

Replies

4
Re: OSGI config edited in repo not applying during runtime - Adobe Experience Manager 03-03-2022
I found one issue and it was really simple and dumb lol. For some reason this: properties.setProperty("homePageUrl", "/content/my-portal/maintenance-page.html"); wasn't actually getting picked up as a string in the datastream. I added a pair of escaped quotes around the url and now it picks up the new string, but only after I manually hit "save all" in crx/de. Is there a way to programmatically perform that action? I thought session.save() should, but that's not working out. properties.setProper...

Views

246

Likes

3

Replies

5
Re: OSGI config edited in repo not applying during runtime - Adobe Experience Manager 03-03-2022
According to that article, my implementation should take effect immediately: Resolution Order at RuntimeConfiguration changes made while the system is running trigger a reload with the modified configuration.Then the following order of precedence applies:Modifying a configuration in the Web console will take immediate effect as it takes precedence at runtime.Modifying a configuration in /apps will take immediate effect.Modifying a configuration in /libs will take immediate effect, unless it is m...

Views

248

Like

1

Replies

0
Re: OSGI config edited in repo not applying during runtime - Adobe Experience Manager 02-03-2022
I am avoiding replication because some of the settings might differ between the author and publisher, but exposing the endpoint sounds like a good alternative! Can you point me to any resources on this method? If I can't get this code to work soon I'll try that instead, thank you!

Views

311

Like

1

Replies

0
Re: OSGI config edited in repo not applying during runtime - Adobe Experience Manager 02-03-2022
I tried that and it doesn't reflect in the console either.

Views

317

Like

1

Replies

2
Re: OSGI config edited in repo not applying during runtime - Adobe Experience Manager 02-03-2022
Yeah that configadmin was leftover from an older version of the code. The reason I'm accessing the repos remotely is that I'm trying to make a button for a tools page on the author instance that changes these settings on two publisher instances. The goal is to give someone other than myself the ability to do this without having to access the system console or crx/de.

Views

327

Like

1

Replies

2
OSGI config edited in repo not applying during runtime - Adobe Experience Manager 02-03-2022
Hello, I have a servlet that is modifying an osgi config in the repo, which is working as intended and reflecting correctly in crx/de, but the new config is not being reflected in the console until I do a restart, and it isn't taking precedence over the previous config either when I hit the page that it applies to. Is there a way to tell the console to check for this new config? Or something missing in my code? Any help is appreciated! Servlet code: @component(service= Servlet.class, property={ ...

Views

365

Like

1

Replies

14
Likes given to