Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

matth39107775
Community profile matth39107775 Level 1
Job title here
Location here
2 BADGES
Level 1

Level 1

Learn more
Joined the community 29-08-2019 11:41:18 AM
Offline
Top badges earned by matth39107775
Customize the badges you want to showcase on your profile
Re: Lazybone: template is not showing up at siteadmin or site page
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
Where are the config nodes?

Views

554

Likes

0

Replies

0
Re: Lazybone: template is not showing up at siteadmin or site page
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
Followed it exactly and it still does not appear in sites. The folder is there and I can add templates, but it does not appear in sites.

Views

545

Likes

0

Replies

0
Re: App not showing in sites and websites of AEM
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
But how do you create content when there isn't a site to assign it to?

Views

1.2K

Likes

0

Replies

0
Re: Byline cannot be resolved to a type using WKND tutorial
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
Okay maybe it was referring to this page http://localhost:4502/libs/granite/ui/content/dumplibs.rebuild.html If that's the case I have followed every instruction on that page to rebuild the cache and got the same error. Using both the file system method and the web console method.

Views

1.9K

Likes

0

Replies

0
Re: Byline cannot be resolved to a type using WKND tutorial
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
I'm trying to recompile everything using those steps but I don't see where in the web console system/console/bundleswhere I can doFor classes and Slightly access [1] and click Recompile all JSPs.For clientlibs access [2], click Invalidate Caches then click Rebuild Libraries. I don't know where those actual options areI also I went to that repo and copy and pasted all the code for each file relating to the byline component to make sure there weren't any differences

Views

1.9K

Likes

0

Replies

0
Re: Byline cannot be resolved to a type using WKND tutorial
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
It seems that option was removed in 6.5 but I followed option 2 on How to force a recompilation of all Sling scripts jsps, java, and sightly in AEM 6.4 and I still received the same error

Views

1.8K

Likes

0

Replies

0
Re: Byline cannot be resolved to a type using WKND tutorial
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
I get "The requested page was not found. If you are not forwarded in 3 seconds to the Web Console, please click here"When visiting that page. I'm using 6.5. I could be wrong but from my research that seems to only apply up to version 6.3

Views

1.9K

Likes

0

Replies

0
Re: Byline cannot be resolved to a type using WKND tutorial
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
Redid the bundle install of core usingin the core folder. Now it appears in the exported packages of the bundle but now I get a new errorNo use provider could resolve identifier com.adobe.aem.guides.wknd.core.components.Byline

Views

1.9K

Likes

0

Replies

0
Re: Byline cannot be resolved to a type using WKND tutorial
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
Looking at the bundles I see that the core bundle doesn't include the byline componentI also I was using mvn -PautoInstallPackage -Padobe-public clean installAt the root of my project.

Views

1.9K

Likes

0

Replies

0
Re: Error while deploying custom AEM component
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
Since my issue was slightly different I just ended up making a separate postByline cannot be resolved to a type using WKND tutorial

Views

5.4K

Likes

0

Replies

0
Byline cannot be resolved to a type using WKND tutorial
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
I've been following along the WKND tutorial here5 - Custom Component The initial steps with creating the byline component without any of the actual logic works, but after I added the Byline class I get I saw someone who was having a similar issue here Re: Error while deploying custom AEM component But in their case it's saying that it resolves to a package. I do not have that error. Mine just says 'Cannot get DefaultSlingScript'Here's how I have everything positioned in eclipse And my byline.htm...

Views

5.2K

Likes

0

Replies

10
Re: Error while deploying custom AEM component
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
Yeah I have2.5.0and com.adobe.cq core.wcm.components.core 2.5.0 provided in my pom.xml but still have the same error

Views

5.4K

Likes

0

Replies

0
Re: Error while deploying custom AEM component
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
What did you update in your configurations? Are you referring to the pom.xml files?

Views

5.4K

Likes

0

Replies

0
Re: Error when creating an AEM project in Eclipse
Avatar
Boost 1
Level 1
matth39107775
Level 1

Like

1 like

Total Posts

14 posts

Correct Reply

0 solutions
Top badges earned
Boost 1
Applaud 5
View profile
matth39107775
- Adobe Experience Manager
I have the same issue. Anyone have any ideas? I also used the finished WKND code so it doesn't have to do with the actual Maven setup process.

Views

1.3K

Like

1

Replies

0