Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn More

View all

Sign in to view all badges

joshuab42862197
Community profile joshuab42862197 Level 2
Job title here
Location here
5 BADGES
Level 2

Level 2

Learn more
Joined the community 26-04-2019 4:04:29 PM
Offline
Top badges earned by joshuab42862197
Customize the badges you want to showcase on your profile
Re: Visitor ID Data Sources
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Analytics
Hey, I wrote a guide to this on my website.That being said, if you use the Marketing Cloud Visitor ID (Adobe Analytics ID) as the value for the `transactionID` column, your upload will work as expected. And you don't need to set anything for `s.visitorID`. This will be populated automatically by the `mcvisid` if `s.visitorID` isn't specified.You can obtain this value from the `mcvisid` column in an Adobe Data Feed.

Views

583

Likes

0

Replies

0
Re: JWT access token: How can I change the expiration?
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Analytics
I'm also having trouble getting this to work correctly. Following Adobe's guidelines, 'exp' should be set as POSIX time (seconds since the Epoch).That can be implemented in Javascript like this: const thirtyMinutesFromNowInSeconds = (Date.now() / 1000) + 30 * 60; However, changing the seconds affects the access token response very little. It seems that no matter what I enter, I get expires_in: 86399995 as the response.Building on this, I think the 'expires_in' parameter returned in the access to...

Views

18.9K

Likes

0

Replies

0
Re: JWT access token: How can I change the expiration?
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Analytics
Building on this, I think the 'expires_in' parameter returned in the access token response can be interpreted as milliseconds. At least I hope. Will be testing this.

Views

18.7K

Likes

0

Replies

0
Re: Classification Rule Builder Not Allowing Variable Selection
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Analytics
You got it. I didn't realize it would disable the classification if it had been used in another rule set.Thank you for the help. After looking through, I found which rule set was using the variable and added my rule there.

Views

1.3K

Likes

0

Replies

0
Classification Rule Builder Not Allowing Variable Selection
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Analytics
I tried making a new classification rule but cannot activate it because my variable selections are greyed out.Has anyone experienced this or have an idea of what to check?

Views

1.7K

Likes

0

Replies

3
Re: Some props writing out in a loop, others not. Why?
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Experience Platform Launch
Due to clearVars()... I didn't think that through. Very strange... The change you made using s.tl(this...) is going to apply a delay to tracking the link. Your original configuration of s.tl(true...) was best.Where are you setting docLength? If this isn't working, it seems like there must be other code causing the bug.Try this:var s=s_gi('mfs-distribution-intranets');s.linkTrackVars='prop1,prop46,prop50';for (var i = 0; i < myDocs.length; i++) { s.prop1=articleIDs[i]; // stores compliance number...

Views

2.4K

Like

1

Replies

0
Re: Some props writing out in a loop, others not. Why?
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Experience Platform Launch
What happens if you define s and s.linkTrackVars outside of the for loop?Setting props to '' shouldn't be necessary as clearVars() will set them as undefined. And null isn't necessary as the fourth argument in s.tl(). These shouldn't affect anything, but simplifying your code could make it easier to find bugs.Are you positive the id you're setting in s_gi() is the name of your report suite?

Views

2.3K

Like

1

Replies

0
Re: Data Element for Page Name Not Sent With Every Hit
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Experience Platform Launch
That makes sense, thanks again. I made this change, and it appears to be working. eVar61 is now always set with the value of pageName.However, I do still have instances where there are more Visits than Page Views which makes me concerned that the pageName isn't being set on every s.t() call, but I don't know how that is possible. This is what I have configured:Have you had instances where data elements are not populated before the beacon is fired?

Views

1.5K

Likes

0

Replies

0
Re: Data Element for Page Name Not Sent With Every Hit
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Experience Platform Launch
I really appreciate your response Andrey. That is a strange and unexpected behavior, but it makes sense.I created the report you suggested and found your hypothesis to hold water:What is confusing, is that this is occurring on hits that are set to use s.t() as well. I attach a "Hit Type" dimension to all hits, and Pageview hits are always sent using s.t():Regardless, I'm going to test setting eVar61 directly to see if that resolves the issue. Do you have any insight on why pageName would be remo...

Views

1.5K

Likes

0

Replies

0
Data Element for Page Name Not Sent With Every Hit
Avatar
Validate 1
Level 2
joshuab42862197
Level 2

Likes

4 likes

Total Posts

10 posts

Correct Reply

1 solution
Top badges earned
Validate 1
Boost 3
Boost 1
Applaud 5
Affirm 1
View profile
joshuab42862197
- Adobe Experience Platform Launch
I have a Data Element set on every hit to generate Page Name. However, there are thousands of hits where it comes through as unspecified, and I don't understand why. Are data elements asynchronous, or is there something else going on?This is what I have set up:Processing rule that copies Page Name to eVar6112% of hits are coming through as unspecified, with no patternAll hits set Page Name using a Data ElementData Element pageName is set as: return _satellite.getVar('pageDomain') + ',' + _satell...

Views

3.4K

Likes

2

Replies

5