since ‎25-01-2018
pn_2007
Level 2
Re: AEM Query date range property to query pn_2007 - Adobe Experience Manager
It worked. Thank you.
108
Views
0
Likes
0
Comments
AEM Query date range property to query pn_2007 - Adobe Experience Manager
I have a query as below: path=/home/project/usersproperty=customGroupproperty.value=Unverifiedtype=rep:User From this result I need to filter whoseregistrationCompletedDate or jcr:createdDate value is greater than 5 days Both these properties are of type Date.Can you help how I need to modify the query ? Do we have any property to get the dte greater than a particular value?
149
Views
0
Likes
3
Answers and Comments
Re: Vanity URL not working through website dispatcher url but https:/{dispatherDomain}/libs/granite/dispatcher/content/vanityUrls.html is listing all vanity urls pn_2007 - Adobe Experience Manager
Found the root cause of this issue. OOB Vanity URL's were not working because of internal sling mapping and dispatcher mapings. So as a solution we implemented custom vanity url path by appending the /content/site/locale path internally thorugh code and now OOB vanity urls are working.
62
Views
0
Likes
0
Replies
Re: AEM - vault -package filter.xml query pn_2007 - Adobe Experience Manager
I tried and this did not work. Also, in my case exclude pattern will not work as we have a designs package which i would like to exclude inorder to remove the dependency between apps and design package. Since the clientlib folder resides in designs package, even though if we give the exlcude ath for designs in the apps filter, it will not work. So we have to go by include pattern only.
189
Views
0
Likes
0
Comments
Re: AEM - vault -package filter.xml query pn_2007 - Adobe Experience Manager
@BrianKasingli I have installed the package manually and saw the changes inside dialog.xml was not refflecting by just giving . I cannot give filter root alone as there are some folder which we don't need to be added as part of the package and hence giving the include patterns and including only those required
212
Views
0
Likes
0
Comments
Re: AEM - vault -package filter.xml query pn_2007 - Adobe Experience Manager
@Albin_Issac If we give , the full nodes under site will be included right which I dont want. Hence given required paths only using include pattern. But my question is if i need to include all nodes and files under , how do i need to give the include pattern?
238
Views
0
Likes
0
Comments
Re: AEM - vault -package filter.xml query pn_2007 - Adobe Experience Manager
@Shashi_Mulugu AEM versio is 6.4, Content maven version is 0.5.1, We are using include pattern so that we can inslude only the required folders other than including everthing in the package.
215
Views
0
Likes
0
Comments
AEM - vault -package filter.xml query pn_2007 - Adobe Experience Manager
In my apps package filter.xml i have give as below: With the above code, when I am deploying my package, any new folders/files created are getting updated in crxde any existing html file changes are getting updated in crxde but changes to component dialog.xml are not getting updated in crxde (to explain, I make changes directly in one of the component dialog in crxde and then i deploy my package. The changes I did are not getting udpated from my codebase is the problem)So then I add the be...
321
Views
0
Likes
10
Answers and Comments
Vanity URL not working through website dispatcher url but https:/{dispatherDomain}/libs/granite/dispatcher/content/vanityUrls.html is listing all vanity urls pn_2007 - Adobe Experience Manager
We are looking forward to make vanity url set up working for our website. We are using AEM 6.4.7 Have followed Adobe documentation and this blog - https://blog.kristianwright.com/2016/02/11/aem-dispatcher-and-vanity-urls/ to set up vanity urls.Dispatcher configuraions in farm file, filter.any file and cache.any file is also done. I am able to access the list of vanity url's using the path - https:/{dispatherDomain}/libs/granite/dispatcher/content/vanityUrls.html. But when i access thorugh the we...
111
Views
0
Likes
1
Replies
Re: Vanity url is not working with dispatcher in AEM 6.4 pn_2007 - Adobe Experience Manager
@Anderson_Hamer Can you please confirm if this issue got resolved? I am also facing the same issue
308
Views
1
Like
2
Replies
var/commerce/products scroll issue in column view after SP 6.4.7 pn_2007 - Adobe Experience Manager
We are using AEM 6.4 and recently installed Service pack 6.4.7. Since after that, product UI(/var/commerce/products/) scroll in column view is not working if you have a huge list of products(1400+)The only error I am seeing is as below: *ERROR* [165.225.209.46 [1594219579524] GET /var/commerce/products/test/report/webAsset.thumbnailAsset.319.png/1592540110195.png HTTP/1.1] org.apache.sling.engine.impl.SlingMainServlet service: Uncaught Problem handling the requestjavax.imageio.IIOException: No d...
83
Views
0
Likes
1
Answers and Comments
Re: Product UI(var/commerce/products) scroll issue after... pn_2007 - Adobe Experience Manager
@vanegi So are you saying this is a known product issue and we need to raise a ticket ith Adobe?
418
Views
0
Likes
0
Comments
Re: Product UI(var/commerce/products) scroll issue after... pn_2007 - Adobe Experience Manager
@vanegi But I could't reproduce this in we retail site. Our project has ,ore than 300 products, so once I insatll that package, I can see that the products are not loading up. In We retail, I couldn't reproduce it as they donot have that many products.
522
Views
0
Likes
0
Comments
Product UI(var/commerce/products) scroll issue after AEM Service pack 6.4.7 installation pn_2007 - Adobe Experience Manager
Hi , We are using AEM 6.4 instance and recently installed Service Pack 6.4.7 in all our instances.Since then we are finding an issue in Product UI.Specific to our project we have 400+ product ui in var/commerce/products path specific to our project.Since installing the latest service pack, the scroll funtionality in product UI is not completely functional. On first scroll, it shows loading and shows the next set of products and this works fine for two scrolls, after that it is not loading the ne...
556
Views
0
Likes
5
Answers and Comments
Re: DAM Asset shown as broken in publish when published pn_2007 - Adobe Experience Manager
Thank you all for your valuable comments on this issue. But the issue was at clouf front level. We had to add another beviour to pass the cookies from cludfront as that was a restrcited access folder.
395
Views
0
Likes
0
Answers
Re: DAM Asset shown as broken in publish when published pn_2007 - Adobe Experience Manager
@ Arun_Patidar Logged in as admin user and i checked the folder permissions too. It is all good in that perspective.
1052
Views
0
Likes
0
Comments
Re: DAM Asset shown as broken in publish when published pn_2007 - Adobe Experience Manager
Did not see any error while uploading in author and able to access image rendition in author
825
Views
0
Likes
0
Comments
Re: DAM Asset shown as broken in publish when published pn_2007 - Adobe Experience Manager
No. Image is not rendering in the page neither. compared both publisher and in both I can see the rendition nodes. Compared them as well
1097
Views
0
Likes
0
Comments
Re: DAM Asset shown as broken in publish when published pn_2007 - Adobe Experience Manager
Another observation is that - I tried to inspect the broken image and could understand that it is referring to 1280*1280 rendition image. This rendition image is geeting downloaded in author instance, when we hit direct rendition image. But in publish direct rendition image is giving 404, though the physical rendition node 1280*1280 exist in JCR.
1161
Views
0
Likes
0
Comments
Re: DAM Asset shown as broken in publish when published pn_2007 - Adobe Experience Manager
@ Veena_Vikram This is happeing in QA. I did check your points 1 and 2 and everything is there. BUt still image is showing as broken.
1171
Views
0
Likes
0
Comments
DAM Asset shown as broken in publish when published pn_2007 - Adobe Experience Manager
I am facing a strange issue as below with DAM assets.Have created a new DAM Folder in author and added some images. Tried publishing just one image from author.Though replication logs say it is successful, when I open the DAM folder in Publish instance. I am seeing the image as broken as below:Though it has been literally published, because I can see the file and file name etc. The image is showing as broken image.Another observation is that - I tried to inspect the broken image and could unders...
2435
Views
0
Likes
12
Answers and Comments
Re: Maven dependency when using opencsv : Unable to start... pn_2007 - Adobe Experience Manager
@ArpitVarshney, Done
2174
Views
0
Likes
0
Comments
Re: Maven dependency when using opencsv : Unable to start... pn_2007 - Adobe Experience Manager
Thank @ArpitVarshney. That fixed the issue. Thanks a lot. You saved my day
2213
Views
0
Likes
0
Comments
Re: Maven dependency when using opencsv : Unable to start... pn_2007 - Adobe Experience Manager
Hi @Albin_Issac My core bundle pom.xml already have an entry like this. org.apache.felixmaven-bundle-plugintrue*;scope=compile|runtime;inline=falsetrue!com.jcraft.jzlib,!android.util,!org.bouncycastle.jce,!org.bouncycastle.jce.spec,javax.inject;version="[1.0,2)",com.adobe.cq.commerce.api;version="[4.0.0,5)",com.adobe.cq.commerce.common;version="[3.0,4)",* I tried changing the inine to true and build again. That too did not fix the issue
1448
Views
0
Likes
0
Comments
Re: Maven dependency when using opencsv : Unable to start... pn_2007 - Adobe Experience Manager
Hi @ArpitVarshney, My core bundle pom.xml has already included * as dependency as below. org.apache.felixmaven-bundle-plugintrue*;scope=compile|runtime;inline=falsetrue!com.jcraft.jzlib,!android.util,!org.bouncycastle.jce,!org.bouncycastle.jce.spec,javax.inject;version="[1.0,2)",com.adobe.cq.commerce.api;version="[4.0.0,5)",com.adobe.cq.commerce.common;version="[3.0,4)",* I tried changing the inine to true and build again. That too did not fix the issue
2252
Views
0
Likes
0
Comments
Maven dependency when using opencsv : Unable to start bundle pn_2007 - Adobe Experience Manager
I am trying to use opencsv in my AEM project. For that I have added the maven dependency as below in my core bundle pom.xml. com.opencsvopencsv4.1 But after adding this dependency, my project bundle is showing installed status and I can see the below when anlaying the bundle.org.apache.log -- Cannot be resolvedorg.apache.avalon.framework.logger -- Cannot be resolved Error.log :missing requirement - Unresolved requirements: osgi.wiring.package; (osgi.wiring.package=org.apache.log) Can someone hel...
3431
Views
1
Like
10
Answers and Comments
Re: How to create a OSGI Configuration holding multi dime... pn_2007 - Adobe Experience Manager
Thank you Briankasingli
4194
Views
0
Likes
0
Comments
Re: How to create a OSGI Configuration holding multi dime... pn_2007 - Adobe Experience Manager
Got another solution. Created 6 different single dimensional string arrays which is supported by OSGI. Then added all these 6 string array to a list and then used that list in my logic and that seems to be working.
4200
Views
0
Likes
0
Comments
Re: How to create a OSGI Configuration holding multi dime... pn_2007 - Adobe Experience Manager
I think, there is a misunderstanding here. We have a config node in our apps folder for each OSGI configuration right. That is basically a xml file where we define our OSGI properties which is then picked by our component or service. How we can define a 2D array in this osgi config node is my question here.
4309
Views
0
Likes
0
Comments
Re: How to create a OSGI Configuration holding multi dime... pn_2007 - Adobe Experience Manager
Thanks Brian for your answer. I understand we have string array representation as below in the osgi xml file like a single array group="[A,B,C,D,E,F]" . But could not get something like an array representation in my question...I am looking for a 2D array representation in the xml file.
4335
Views
0
Likes
0
Comments
Likes given to
Likes from