Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

ArpitVarshney
ArpitVarshney
Offline

Badges

Badges
27

Accepted Solutions

Accepted Solutions
36

Likes

Likes
143

Posts

Posts
190

Discussions

Discussions
31

Questions

Questions
159

Ideas

Ideas
0

Blog Posts

Blog Posts
0
Top badges earned by ArpitVarshney
Customize the badges you want to showcase on your profile
Re: Unresolved dependency after installing service pack 6...
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @ruchim71073425 Could you please verify:If you have updated the custom aem code to use aem 6.4.8 uber jar? You have to update pom uber version like below: com.adobe.aem uber-jar 6.4.8 provided Also, the mentioned package com.adobe.aemds.guide.aemds-guide-core-impl is related to AEM forms package which might be missing in your local instance. You need to verify if the AEM version 6.4.8 support different version of the package which might be located here https://helpx.adobe.com/in/aem-forms/kb...

Views

518

Likes

2

Replies

1
Re: AEM 6.5 Kafka Streams (org.apache.kafka) Package cann...
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @aem-enthusiast After adding maven dependency, please verify the tag of maven-bundle-plugin [You can either include all the dependencies or you can configure to not include specific ones]. The scope attribute lets you configure which dependency jars you want to include based on their include scope. You should not include the dependencies which are only needed for compile and for the test.Below is the example to add the kafka-streams & kafka-clients to the embed dependency in your core pom.xm...

Views

503

Likes

2

Replies

0
Re: Multi-field Validation.!
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @imadullakhan Please go through this blog https://blogs.perficient.com/2018/10/26/simple-multifield-max-item-validation-for-aem-6-4/It will help you with your usecase. Regards,Arpit Varshney

Views

549

Like

1

Replies

0
Re: how to achieve re usability of components within diff...
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @vijayt86226372 I'm assuming this is probably because of different client libraries for multiple websites. The best way I can think is that you can extract the generic components which need to be used across all the websites. Just create a base clientlib for those components and embed this base clientlib in all the other site client libraries and remove the duplicate code from site-specific clientlibs and then you can use style system to define the variation of your component and author in we...

Views

699

Like

1

Replies

1
Re: Incorrect Sidekick's behaviour
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @ashutoshrastogi I would say you should drag/drop/edit the classic UI component in classic UI mode and touch UI component in touch UI mode.Also, Adobe has already recommended everyone to move from classic to touch UI mode so I would suggest you move your components from classic to touch gradually but at least you can convert these dialogs from classic to touch which are pretty easy using dialog converter tool. Regards,Arpit

Views

516

Like

1

Replies

0
Re: WCM core upgrade to 2.9.0 with 6.5.3
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @chandeshj240320 As per their documentation, the system requirement is (Reference https://github.com/adobe/aem-core-wcm-components/blob/master/VERSIONS.md)Core Components Historical System Requirements: Core 2.9.0 AEM 6.5.4.0+AEM 6.4.8.0+ Java 8, 11 They only mention supporting version 6.5.4.0+ for AEM 6.5. So, I would recommend you upgrade your AEM instance to service pack 6.5.4.0+ if you want to proceed with the latest core component and want to avoid any unexpected issue. Regards,Arpit Var...

Views

894

Like

1

Replies

1
Re: AEM servlet not render in publisher instance
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @sajithv You might have missed publishing or deploy all the custom code written for this component which contains your java, JSP, client lib. Just validate your changes by logging as admin in publish instance.Just validate if the content got successfully replicated after authoring this component.Regards,Arpit

Views

1.2K

Likes

2

Replies

0
Re: How can I get assistance to buy the AEM?
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
@kautuk_sahni Could you please guide here?

Views

1.3K

Likes

0

Replies

0
Re: How can I get assistance to buy the AEM?
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @PilyDG Have you tried contacting Adobe's sales team using this link https://www.adobe.com/request-consultation/experience-cloud.htmlThey will help you. Regards,Arpit

Views

1.3K

Like

1

Replies

2
Re: change in header/footer
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @dhiraj85 The clientlibs in AEM consists of JS and CSS and in some instances they get cached; which as would be obvious; causes issues.To remove this cache and rebuild the clientlibs, following link is quite useful::/libs/granite/ui/content/dumplibs.rebuild.html There are individual buttons to invalidate cache and rebuild the libraries on this page. Regards,Arpit

Views

2.7K

Likes

0

Replies

0
Re: change in header/footer
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @dhiraj85 try to clear your browser cache or open your page in incognito mode of browser and validate.If that doesn't work then recompile your clientlib as @berliant says. RegardsArpit

Views

2.8K

Likes

0

Replies

0
Re: MSM with Translation framework
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @JanHumpal  Yes, you understood right.

Views

1.4K

Likes

0

Replies

0
Re: change in header/footer
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @dhiraj85 It is possible that your CSS changes are getting overridden in your style.css. Like for example:if you have a span element like this in footer component:Testand style.css is like this to apply background:span {background-color: black;}span {background-color: white;} Then the last property will override the previous property and all span will have background color as white. Recommended way to solve is that you can give a class to span and target that class in CSSTestand style.css is:...

Views

2.8K

Like

1

Replies

4
Re: Google text to speech and vice versa
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @onkarh71407069 You can create a component in AEM and call the google rest API to achieve this requirement.REST API Reference Guide:https://cloud.google.com/text-to-speech/docs/reference/rest Regards,Arpit

Views

956

Like

1

Replies

0
Re: MSM with Translation framework
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @JanHumpal Using bootstrap conenctor, One can integrate with human and machine translators to create language copies in AEM. When you create a language copy in AEM, it asks for pages/assets that need to be translated and after selecting it, AEM translation Management process the source content and translates the content using the translation provider selected during translation. It creates a similar structure in AEM. Suppose if you want to translate whole sites of we.retail Canada English who...

Views

1.4K

Likes

2

Replies

3
Re: How to Adapt ContentFragment in tests
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @aliaksandr_hvoz Your code seems to be correct. However, you can go through this link https://docs.adobe.com/content/help/en/experience-manager-64/developing/extending-aem/customizing-content-fragments.html Also, Could you please confirm which type of resource resolver you are using?Are you creating resource resolver via service user? If yes, could you please verify whether the corresponding service user has the read access to the content fragment and service mapping is present in OSGI. (refe...

Views

2.3K

Like

1

Replies

1
Re: Regarding RTE Styles
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @SreekanthReddy , It might be possible the content is copied from somewhere and while pasting it took the formatting of the source text.Can you reauthor your text in rte after removing the source formatting?[You can use various method to remove formatting like an online tool https://www.textcleanr.com/# or copy the text in word and remove formatting before pasting it in richtext] Regards,Arpit

Views

1.2K

Like

1

Replies

0
Re: Download Adobe Experience Manager
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @Raks98 AEM is a licensed product. You can reach out to Adobe's sales team using this link https://www.adobe.com/request-consultation/experience-cloud.html. Regards,Arpit Varshney

Views

1.2K

Like

1

Replies

0
Re: React and AEM SPA Editor - Build Error!
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @jezwn It should be there at the parent pom.xml.The tag must be present in the react-aem/pom.xml file. I think you are checking your frontend module pom. Regards,Arpit

Views

2.5K

Likes

0

Replies

0
Re: AEM sightly Binding Issue.!
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @imadullakhan If you are looking for a reference, you can go through the below link which lets you select a 1.5,2.5 rating as well. https://codepen.io/tonkin/pen/MWwWGGg If you want to pass the selected value to the backend, you can write an ajax request while the user selects any rating. This logic needs to implemented in JS. Regards,Arpit

Views

1.2K

Like

1

Replies

0
Re: React and AEM SPA Editor - Build Error!
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @jezwn From the error shared by you, it seems like the start and end tag of in your pom.xml doesn't match.Could you please validate. For example, it should be like below:https://repo.adobe.com/nexus/content/groups/public

Views

2.5K

Like

1

Replies

4
Re: Restrict Access to Custom Workflow Model (Create -> W...
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @sg08 Can you go through this thread https://experienceleaguecommunities.adobe.com/t5/adobe-experience-manager/restrict-ootb-workflow-for-customgroup/qaq-p/283677 Regards,Arpit Varshney

Views

1.2K

Like

1

Replies

0
Re: WKND Sites Project getting connection refused for ui....
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @martinlloyd Make sure your target AEM instance is started and running normally(all bundles should be active) before you deploy your code.If you have changed the admin username and password of your AEM instance, you might need to update it in your pom.xml.If you want to deploy your code to author instance running on the port 4502 then use mvn clean install -PautoInstallPackageIf you want to deploy your code to publish instance running on the port 4503 then use mvn clean install -PautoInstallP...

Views

1.6K

Likes

2

Replies

0
Re: AEM Import and Export Bundle
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @sg08 You need to understand the concept of the Bundle Resolution Rule in OSGi.This is very well explained in this link.https://blog.christianposta.com/osgi/understanding-how-osgi-bundles-get-resolved-part-i/ Regards,Arpit Varshney

Views

2.6K

Likes

3

Replies

1
Re: Remove replicate permission for administrators - AEM 6.4
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @skmAem I think it is not possible to change admin permission by anyway. Even though you will deny for everyone, admin can still access it because of its role in AEM. Regards,Arpit

Views

1.8K

Likes

0

Replies

0
Re: Maven dependency when using opencsv : Unable to start...
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
No problem @pn_2007 , you can mark my answer as correct if that fixes your issue so that it will be good for other 🙂

Views

4.5K

Likes

0

Replies

0
Re: Maven dependency when using opencsv : Unable to start...
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @pn_2007 Please add !org.apache.log & !org.apache.avalon.framework.logger in existing tag of maven-bundle-plugin like below. org.apache.felix maven-bundle-plugin true !org.apache.log, !org.apache.avalon.framework.logger *; |opencsv true

Views

4.6K

Likes

0

Replies

0
Re: Spesific Child Pages & dynamic cannonical
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @iwanttobeDev This is not a good way to achieve this requirement. This is not a generic solution.You should try @Shashi_Mulugu approach for this. regards,Arpit

Views

1.3K

Likes

0

Replies

0
Re: Remove replicate permission for administrators - AEM 6.4
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @skmAem I'm not sure but you can't change admin permission in AEM. If you try to do so, it will revert back to default again.The role of admin to control and manage everything so restricting it for any action won't make any sense. Regards,Arpit Varshney

Views

1.2K

Likes

2

Replies

0
Re: Do we need /all and /repository-structure in newly cr...
Avatar
Springboard
Community Advisor
ArpitVarshney
Community Advisor

Likes

143 likes

Total Posts

190 posts

Correct reply

36 solutions
Top badges earned
Springboard
Ignite 5
Ignite 3
Ignite 1
Give Back 100
View profile
ArpitVarshney
- Adobe Experience Manager
Hi @ramaem12 Please go through the link https://docs.adobe.com/content/help/en/experience-manager-cloud-service/implementing/developing/aem-project-content-package-structure.html to understand the AEM latest project structure. Regards,Arpit

Views

1.1K

Likes

2

Replies

0