Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

viveksachdeva
Community profile viveksachdeva Level 7
Job title here
Location here
27 BADGES
Level 7

Level 7

Learn more
Joined the community 05-01-2015 9:55:47 PM
Offline
Top badges earned by viveksachdeva
Customize the badges you want to showcase on your profile
Re: What is the best way to add more properties to the page component?
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
I think there would be some JS error.. Possible that the dialog got copied under incorrect node.. Can verify the hierarchy of your new component? If there is a sample package that you can share, that will be great... Could you also check browser console and share JS error, if you see any?P.S. overlaying(that works for you) is better practice. So your work is accomplished but it would be good to find out root cause of this issue.

Views

243

Likes

0

Replies

0
Re: Comparison component
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
IMO, should use JS templating - Dust, Handlebar or something.- Create a template for product comparison that takes a JS object containing details of all products.- On click of compare, feed this template the JS object and render it.

Views

296

Likes

0

Replies

0
Re: AEM BulkEditor Tool
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Here is an article talking about similar issue.. This was 5.6.. Shouldnt be any different in higher version as well..AEM(CQ5.6) BULK EDITOR Extension Part 1 | TO THE NEW Blog Cheers!!

Views

321

Likes

0

Replies

0
Re: What is the best way to add more properties to the page component?
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Should not copy paste whole dialog. That defeats the purpose of resource merger. Here is a link that does similar to what you are doing GitHub - Adobe-Marketing-Cloud/aem-authoring-extension-page-dialog​ . But still its strange that copying the dialog doesnt work. Could you add details exactly what doesnt work? Does the dialog not open or it still shows old fields?

Views

242

Likes

0

Replies

0
Re: Translation connector - implementation for scope requests
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Do you happen to have sample code on github in which you are facing issue?

Views

549

Likes

0

Replies

0
Re: Issues after upgrade from AEM 6.1 to AEM 6.3
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
I dont think users would be removed after upgrade. You can still try and add user named "monitoringScripts", make it a system user and run AEM again..

Views

4.5K

Likes

0

Replies

0
Re: Issues after upgrade from AEM 6.1 to AEM 6.3
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
I do see a system user named "monitoringScripts" in Vanilla AEM 6.3 along with the service mapping. Could you check if it is there after upgrade as well?

Views

4.5K

Likes

0

Replies

1
Re: AEM BulkEditor Tool
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Added a custom multifield property.. On search it appears as comma separated property.. You can just add more values there and save.. Hope this works for you..

Views

324

Likes

0

Replies

0
Re: Facing issues in bundle resolution
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
It would be great if you can create a github project with what you have. Someone can pick it up from there. It will save a lot of time..

Views

1.9K

Likes

0

Replies

0
Re: Spell Check is not working in AEM 6.1
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
I started from scratch.. with 5.6, added " and spellcheck was working there.. Deployed same code on 6.3 => Not working, which was expected as I did not have the index definition..From Jackrabbit Oak – Lucene Index , created index definition for spell check.. and executed query similar to what I had for 5.6.. "/jcr:root[rep:spellcheck('Canad')]/(rep:spellcheck())" and I could see spell check result.P.S. : There is a difference in resultset for oak as it returns actual results instead of nodes.. S...

Views

2.2K

Likes

0

Replies

0
Re: [New] Welcome to AEM Community! Please Introduce Yourself
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Hi,My name is Vivek Sachdeva. I am currently working as Technical Architect - AEM with VML Singapore. My total work experience is 6.5 years out of which about 4.5 years is in AEM. When not working, I like travelling, playing ping pong and cricket.Cheers!

Views

9.4K

Like

1

Replies

0
Re: Content sync URL Phonegap
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
The problem is that on my AEM instance tiles are not visible the way it is there in the blog. When you have vanila instance of AEM 6.0, you have a different UI for Apps. If I specify server URL there, it doesnt go with the build(I an not able to find server URL in phone gap build)

Views

291

Likes

0

Replies

0
Content sync URL Phonegap
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
I need to update content of phonegap app but I am not really sure where to specify the URL for update server. I found http://adobedocsdiff.headwire.com/sitediff/serve/2015-01-30/data/docs/en/aem/6-0/develop/mobile/apps/managing-aem-mobile-apps/application-details-tile.html.diff article but tiles like this are not visible on my AEM instance. Can anyone tell me where in the app do I need to specify content sync URL so it goes with the build and content is updated. Also how can I verify that my pho...

Views

354

Likes

0

Replies

2
Re: Doubt on ResourceType, Allowed Children,AllowedParent in http://docs.adobe.com/docs/en/aem/6-0/develop/the-basics/website.html
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Straight from documentation. I believe this is self explanatory ResourceType -- path of resource that contains rendering script for this templateAllowed Parents -- Path of a template that is allowed to be a parent of this templateAllowed Children -- Path of a template that is allowed to be a child of this template. https://docs.adobe.com/docs/en/aem/6-0/develop/the-basics/templates.html

Views

236

Likes

0

Replies

0
Re: Extending foundation components that use a single script
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Then only way I see it is extending it and have your own rendering jsp.

Views

390

Likes

0

Replies

0
Re: Extending foundation components that use a single script
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Where do you need to add this additional icon... If you need to change icon of the component that is visible in sidekick, it should just work if you specify resourceSuperType in custom component and add new icon to your custom component.

Views

401

Likes

0

Replies

0
Re: Problem with Parsys
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Add at end of component jsp

Views

310

Likes

0

Replies

0
Re: Issue with suspending and resuming workflows
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Thanks.. Will try that out... Anything about second point: workflow completes whole step even if I suspend it in the beginning of step... Is that correct/expected

Views

597

Likes

0

Replies

0
Re: Issue with suspending and resuming workflows
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Nothing... It just doesnt proceed to next step

Views

581

Likes

0

Replies

0
Re: Issue with suspending and resuming workflows
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Yes.. I am passing correct I'd. Moreover resuming it from the console also doesn't take it any further.. It just says workflow running with first step completed with no info on next step which is a participant step... And even on suspending it. It continues on to complete that step and then suspends the workflow

Views

580

Likes

0

Replies

0
Re: Issue with suspending and resuming workflows
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Woo.. Thats strange... So do I need to call resume and then complete or just complete.. And workflow completes whole step even if I suspend it in the beginning of step... Is that correct/expected

Views

568

Likes

0

Replies

0
Issue with suspending and resuming workflows
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
When I call workflowSession.suspend() from any step, the workflow gets suspended after completing the whole step(I expected it to suspend right at the point when I called suspend method) and I am not able to resume it again using worfsess.resume(). It stays as it was earlier. When I resume it from console, the status changes to "Running"but it doesnt proceed any further. Has anyone faced something like this?

Views

1.6K

Likes

0

Replies

9
Re: Issue while creating user with profile image
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
But AccountManager has utilities to manage everything automatically. By simply passing a map, it creates user with profile properties. In UserManager it just creates a user but account information still needs to be persisted manually.https://docs.adobe.com/docs/en/cq/5-6-1/javadoc/com/day/cq/security/AccountManager.htmlIt seems to be better than UserManger when it comes to persisting profile info along with registration.

Views

276

Likes

0

Replies

0
Issue while creating user with profile image
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
I am using AccountManager API to create users. It works just fine when I dont use profile image in registration form and user gets registered but when I use profile image, I get following error:Caused by: javax.jcr.nodetype.ConstraintViolationException: No matching property definition: jcr:primaryType = sling:Folderat org.apache.jackrabbit.oak.jcr.delegate.NodeDelegate.setProperty(NodeDelegate.java:522)at org.apache.jackrabbit.oak.jcr.session.NodeImpl$35.perform(NodeImpl.java:1308)at org.apache....

Views

382

Likes

0

Replies

2
Re: Custom Workflows
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Yup..workflowSession.complete(workItem, workflowSession.getRoutes(workItem, false).get(0));adminSession.save();

Views

184

Likes

0

Replies

0
Re: Custom Workflows
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
I tried this and it works when I save the session

Views

156

Likes

0

Replies

0
Re: 500 JSON Exception Error while Integrating salesforce and AEM
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
You can try http://www.tothenew.com/blog/integrating-salesforce-with-cq5/

Views

213

Likes

0

Replies

0
Re: AEM 6.0 - Content Sync does not work for Apps
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Not able to get content sync working... The server URL that I entered from the apps console does not appear to be going with the build.. Any idea how I can do that?

Views

753

Likes

0

Replies

0
Re: Issue in creating segment with "product" trait
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
It seems to be a bug. I got it to work by entering full product product along with the hash, something like "/content/geometrixx-outdoors/en/men/shirts/ashanti-nomad.html#mnapan". In pathfield for product trait, we can specify product node and that is not getting resolved, so it looks like a bug to me.

Views

153

Likes

0

Replies

0
Re: Issue in creating segment with "product" trait
Avatar
Give Back 200
Level 7
viveksachdeva
Level 7

Likes

55 likes

Total Posts

225 posts

Correct reply

35 solutions
Top badges earned
Give Back 200
Give Back 100
Ignite 10
Give Back 50
Give Back 25
View profile
viveksachdeva
- Adobe Experience Manager
Yes it should. I checked it on the segmentation page(http://localhost:4502/etc/segmentation/geometrixx-outdoors/test-segment.html). Traits like gender and age are getting resolved but products trait is not. It is there in client context though... 😞

Views

153

Likes

0

Replies

0