Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

samsundar23
Community profile samsundar23 Level 4
Job title here
Location here
16 BADGES
Level 4

Level 4

Learn more
Joined the community 06-07-2020 1:56:16 AM
Offline
Top badges earned by samsundar23
Customize the badges you want to showcase on your profile
com.day.cq.dam.api.s7dam.scene7 does not exist after uber-jar-6.5.7 upgrade
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
I'm upgrading SP7 to my AEM 6.5.After updating uber-jar-6.5.7 in my pom.xml. I get the below error.Kindly help. [INFO] BUILD FAILURE[INFO] ------------------------------------------------------------------------[INFO] Total time: 39.045 s[INFO] Finished at: 2021-03-04T12:43:10+05:30[INFO] Final Memory: 34M/397M[INFO] ------------------------------------------------------------------------[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) o...

Views

373

Likes

0

Replies

5
Re: Upgrading Uber-jar 6.5.7 throwing me error after version update
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Thanks for your suggestion. It worked for me.

Views

1.0K

Likes

0

Replies

0
Re: Upgrading Uber-jar 6.5.7 throwing me error after vers...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Sanket_Kumbharkhane, Thanks for your suggestion. It worked for me. Thanks

Views

1.0K

Likes

0

Replies

0
Upgrading Uber-jar 6.5.7 throwing me error after version update
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
I'm using AEM 6.5 and currently we are using SP1 and we are upgrading to SP7 now.Hence, in the process of uber-jar version upgrade. I have updated to below version in my pom.xml of the project as below. com.adobe.aem uber-jar 6.5.7 provided apisBut I'm experiencing the below error after uber-jar version upgrade although the previous version of uber-jar(6.3.1) was working absolutely fine. Kindly help me to resolve this problem. [INFO] Scanning for projects...[INFO] -------------------------------...

Views

1.0K

Likes

0

Replies

4
Re: Need to show and hide a field description based on th...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
@Anudeep_Garnepudi bro,It worked for me.Thanks for your help. I want to expertise myself in clientlibs. Suggest me good links to have a good learning. 🙂 Thanks

Views

297

Likes

0

Replies

0
Re: Need to show and hide a field description based on th...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
yes @Anudeep_Garnepudi During dialog load it must retain the same behavior.My code change impacted the other tab field description which should not be the case. ThanksSHYAMSUNDAR TK

Views

315

Likes

0

Replies

0
Re: Need to show and hide a field description based on th...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Anudeep_Garnepudi , I'm using the below clientlib script which hiding the field description from third tab (which is wrong).I need to show/hide field description based on the drop-down selection which should be applicable only that particular tab.Can you help me with the correct modification in the below code. (function(document, $, ns) {"use strict";$(document).on("dialog-closed", function() {window.location.reload();});// below method will be triggered during dialog load$(document).on("dia...

Views

329

Likes

0

Replies

0
Re: Need to show and hide a field description based on th...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Thanks a lot @Anudeep_Garnepudi !Your recommendation worked wonders for me.🙂

Views

386

Likes

0

Replies

0
Need to show and hide a field description based on the drop-down selection
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
I'm using AEM 6.5 and I want to show the field description only for "no-image" drop-down value.I want to hide the field description for rest of all drop-down selection.Kindly let me know an option to do this activity (i.e., show and hide the field description based on drop-down selection.). ThanksSHYAMSUNDAR TK

Views

485

Likes

0

Replies

11
Re: Need to get the last subjected date for the workflow...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Thanks bro @Arun_Patidar Based on your input I could get the workflowInstance node path which was last subjected. You suggested to adapt to a node/workflow API to get start date of last workflow used. Does it mean should I be writing a dedicated java class for this query to be executed and then adapt the final output node to a node API and then get the start time as a result ?Is there any other possibility to get the start date as the direct output in querybuilder ?Do correct me if I'm wrong.

Views

358

Likes

0

Replies

0
Re: Need to get the last subjected date for the workflow...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Arun_Patidar , Thanks for your inputs.I want to get start date as a result for the query executed.For instance, if page-name-change is the custom workflow for which I want to get last time this workflow is subjected in AEM author instance.Kindly let me know the way. ThanksSHYAMSUNDAR TK

Views

383

Likes

0

Replies

0
Need to get the last subjected date for the workflow using AEM querybuilder
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
I'm using AEM 6.5.I want to get the start date as a result when was the last time the particular workflow is subjected using aem query builder.https://author.test.com/libs/cq/search/content/querydebug.htmlI tried multiple queries which was not giving the result needed for me. I mean the last time the workflow is used.I tired below query which was not giving me the expected result;path=/var/workflow/instances/server0type=cq:Workflow1_property=status1_property.value=COMPLETED2_property=modelId2_pr...

Views

438

Likes

0

Replies

6
Re: Tab hide not working in dialog-ready but its working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Thanks for all your inputs @Manjunath_K and @Jineet_Vora.banner.js file [show and hide of the tab based on drop-down selection "no-image"] (function(document, $, ns) { "use strict"; $(document).on("dialog-closed", function() { window.location.reload(); }); // below method will be triggered during dialog load $(document).on("dialog-loaded", function (event) { $(".no-image").each(function () { Coral.commons.ready($(this), function (element) { var product = element.val(); showHide(product); }); });...

Views

254

Like

1

Replies

0
Re: Tab hide not working in dialog-ready but its working in onchange method
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Manjunath_K Please find the content.xml and banner.jsNow, even my on change which was working earlier is not working. 😞I tried to search the class image-field-tab in the view-source of html but I could not see it.Please help me. content.xml [please check columnimage from below xml which is the Tab im trying to hide if No image drop-down is selected.] banner.js attached as screenshot ThanksSS

Views

354

Likes

0

Replies

0
Re: Tab hide not working in dialog-ready but its working in onchange method
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Manjunath_K Still the same problem exists.I added layoutConfig with class 'image-field-tab' as you said in the . Still the image tab does not hide when i open the dialog although my selection was 'no-image' when I last applied from drop-down.Kindly help me out.ThanksSS

Views

384

Likes

0

Replies

0
Tab hide not working in dialog-ready but its working in onchange method
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
This is a pretty straight forward question. I'm trying to hide a tab based on drop-down selection. I have added the granite:class as image-tab for the tab to be hided. The below piece of code is working for onchange method when ever i change drop-down, I get to see the Image tab getting hided. But the same is not retained during dialog-ready.I get value of 'a' as undefined.Please help me to resolve. Please find the below clientlibs for the same.(function(document, $, ns) {"use strict";$(document...

Views

437

Likes

0

Replies

8
Re: Content path in pathfield/pathbrowser is not working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Jineet_Vora Apologize to bother you again. I want to append .html at the end of any /content path using resource.resolver.mapping available in theconfig (/apps/environment/publisher/config.publish/org.apache.sling.jcr.resource.internal.JcrResourceResolverFactoryImpl.config)Any way to do it ? Please help. ThanksSHYAMSUNDAR TK

Views

456

Likes

0

Replies

0
Re: Content path in pathfield/pathbrowser is not working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Jineet_Vora Can you explain about these rules which is already in the path/apps/environment/publisher/config.publish/org.apache.sling.jcr.resource.internal.JcrResourceResolverFactoryImpl.config /content/shared/$1/$3/$4/$2>/guidance/([A-Za-z-]+)/(.+)-(\d{4})(\d{2})/content/shared/([A-Za-z-]+)/(\d{4})/(\d{2})/(.+).html

Views

465

Likes

0

Replies

0
Re: Content path in pathfield/pathbrowser is not working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Exactly the same problem as you said.Need some work-around for this issue. ThanksSHYAMSUNDAR TK

Views

532

Likes

0

Replies

0
Re: Content path in pathfield/pathbrowser is not working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Jineet_Vora Your recommendations are spot-on. (Y) I assume there is no /content in the dispatcher URLs which is making it not work.To be specific there is no common keyword I thought to add in match and internalRedirect to make it work.Is there any change which i could make in the sling: match or sling: internalRedirect which could make it work generically. My dispatcher URLs are not working.https://zbank.dev.com/cmpy/about-us https://zbank.dev.com/articles/retirement-age ThanksSHYAMSUNDAR T...

Views

560

Likes

0

Replies

0
Re: Content path in pathfield/pathbrowser is not working in AEM Publish although content path valid
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Thanks @Jineet_Vora for all your recommendations.

Views

576

Likes

0

Replies

0
Re: Content path in pathfield/pathbrowser is not working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Jineet_Vora Thanks a lot for all your inputs. 🙂Your recommendations are working for dispatcher pages which has /content in it. Can you provide your recommendation for my dispatcher page if its going to have only short URLs as below;https://zbank.dev.com/about-us.htmlAny sling:internalRedirect (or) sling:match change which could make it work for the short URLs too.Kindly help. ThanksSHYAMSUNDAR TK

Views

625

Likes

0

Replies

0
Re: Content path in pathfield/pathbrowser is not working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @yjinee94, Please find the below screenshot - I checked in both author and publish instance for the below section and nothing is checked in terms of extension less URLs which are coming up. ThanksSHYAMSUNDAR TK

Views

660

Likes

0

Replies

0
Re: Content path in pathfield/pathbrowser is not working...
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @yjinee94 ,Thanks for the info.With or without the html the content is coming up. My requirement is to append .html after moving to the corresponding page on clicking the pathfield link.For instance, If I have authored /content/xxx-bbb/bunk/about-us in pathfield and I should be moving to /content/xxx-bbb/bunk/about-us.html in my publish instance. Is there any way to append .html as well using the etc/map option which you have suggested ?Please help. ThanksSHYAMSUNDAR TK

Views

712

Likes

0

Replies

0
Content path in pathfield/pathbrowser is not working in AEM Publish although content path valid
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Im authoring the content path in pathfield in my author instance which is a valid content path.After publishing, in publish instance its not rendering to that html content page after I click the link.When I observed its due to the .html is not appending in the content path.I don't want to add .html in my component as we have huge number of components to change.I want to handle in AEM itself and I don't want to use apache rewrite url to append .html.I have gone through etc/map but I'm not sure ho...

Views

766

Likes

0

Replies

12
Re: Problem in pathfield in AEM 6.5
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Thanks @Vijayalakshmi_S To turn off suggestion, below highlighted in green - within is responsible for the rendering of suggestion. You can create a new resource similar to OOB pathfield and comment this line -> Use the newly created resource to dialog field for authoring External Link.

Views

476

Likes

0

Replies

0
Re: Problem in pathfield in AEM 6.5
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Great suggestion indeed ! Bravo. @Vijayalakshmi_S 

Views

523

Likes

0

Replies

0
Re: Problem in pathfield in AEM 6.5
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
.

Views

558

Likes

0

Replies

0
Re: Problem in pathfield in AEM 6.5
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
Hi @Vijayalakshmi_S Thanks for your suggestion. If that is the case, is there any way to restrict the auto-suggestion coming up while using pathfield which is the reason behind this entire root cause analysis.

Views

561

Likes

0

Replies

0
Problem in pathfield in AEM 6.5
Avatar
Boost 5
Level 4
samsundar23
Level 4

Likes

5 likes

Total Posts

66 posts

Correct reply

0 solutions
Top badges earned
Boost 5
Ignite 20
Give Back 50
Give Back 25
Give Back 10
View profile
samsundar23
- Adobe Experience Manager
I'm experiencing a problem in pathfield in AEM 6.5 I'm authoring an external link(http://www.google.com) in the pathfield and an auto-suggestion is coming up. When I moved to the previous field the cursor automatically jumps to pathfield again. This is causing a bit of inconsistency for the authors where most of the pathfields are authored with external link. Is there any way to control the auto suggestion in pathfield.(Refer screenshot 1a) - pathfield behavior (Or)Shall I modify the resourceTyp...

Views

680

Likes

0

Replies

6
Likes from