Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Second instance of Analytics: new tracking code variable(s_code)is not defined

Avatar

Level 1

Hi,

I'm trying to migrate my Analytics implementation to DTM by building a second instance and have the old and the new one run in parallel for a while before disabling the old one.

When i browse the site in with DTM staging mode enabled to test the setup, i see that the alternate tracking code variable i specified for the new version is not being defined. Instead, i get Analytics server calls from the old installation with a mix of variables values from both designs.

I don't assign values in custom scripts directly in any rules (s.eVar1="asd", etc) 

Are there other settings than the one included in the screengrab that needs to be configured?

The old instance is configured through AEM5.6.1 with H.25

the new one use whatever DTM includes by default

Any suggestions?

1 Accepted Solution

Avatar

Correct answer by
Level 1

taciac wrote...

Hi Phil,

How is DTM configured? If the box is checked that 'page code is already present' DTM would be adding to the already existing implementation. For more information on migrating to DTM check out the following links: 

https://helpx.adobe.com/dtm/kb/getting-started-with-activation-dynamic-tag-manager-dtm/getting-start...

https://helpx.adobe.com/dtm/kb/troubleshooting---why-is-appmeasurement-library-conflicting-with0.htm...

Best,

Tacia

 

 

In our case, we wanted to switch to DTM and upgrade the library at the same time. Using the legacy existing code was not an option. We ended up doing a site update to swap out the previous installation and swap in the new version using DTM. It ended up working, but with more efforts and troubleshooting that we would have wanted.

View solution in original post

4 Replies

Avatar

Level 1

PhilBourgeois wrote...

Hi,

I'm trying to migrate my Analytics implementation to DTM by building a second instance and have the old and the new one run in parallel for a while before disabling the old one.

When i browse the site in with DTM staging mode enabled to test the setup, i see that the alternate tracking code variable i specified for the new version is not being defined. Instead, i get Analytics server calls from the old installation with a mix of variables values from both designs.

I don't assign values in custom scripts directly in any rules (s.eVar1="asd", etc) 

Are there other settings than the one included in the screengrab that needs to be configured?

The old instance is configured through AEM5.6.1 with H.25

the new one use whatever DTM includes by default

Any suggestions?

 

 

 

I`ve the same problem

Avatar

Level 9

Hi Phil,

How is DTM configured? If the box is checked that 'page code is already present' DTM would be adding to the already existing implementation. For more information on migrating to DTM check out the following links: 

https://helpx.adobe.com/dtm/kb/getting-started-with-activation-dynamic-tag-manager-dtm/getting-start...

https://helpx.adobe.com/dtm/kb/troubleshooting---why-is-appmeasurement-library-conflicting-with0.htm...

Best,

Tacia

Avatar

Correct answer by
Level 1

taciac wrote...

Hi Phil,

How is DTM configured? If the box is checked that 'page code is already present' DTM would be adding to the already existing implementation. For more information on migrating to DTM check out the following links: 

https://helpx.adobe.com/dtm/kb/getting-started-with-activation-dynamic-tag-manager-dtm/getting-start...

https://helpx.adobe.com/dtm/kb/troubleshooting---why-is-appmeasurement-library-conflicting-with0.htm...

Best,

Tacia

 

 

In our case, we wanted to switch to DTM and upgrade the library at the same time. Using the legacy existing code was not an option. We ended up doing a site update to swap out the previous installation and swap in the new version using DTM. It ended up working, but with more efforts and troubleshooting that we would have wanted.

Avatar

Level 9

PhilBourgeois wrote...

taciac wrote...

Hi Phil,

How is DTM configured? If the box is checked that 'page code is already present' DTM would be adding to the already existing implementation. For more information on migrating to DTM check out the following links: 

https://helpx.adobe.com/dtm/kb/getting-started-with-activation-dynamic-tag-manager-dtm/getting-start...

https://helpx.adobe.com/dtm/kb/troubleshooting---why-is-appmeasurement-library-conflicting-with0.htm...

Best,

Tacia

 

 

In our case, we wanted to switch to DTM and upgrade the library at the same time. Using the legacy existing code was not an option. We ended up doing a site update to swap out the previous installation and swap in the new version using DTM. It ended up working, but with more efforts and troubleshooting that we would have wanted.

 

Thanks for the quick reply. Glad to hear it's working now. 

-Tacia