Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

S-Code-Contents JS loaded twice on page by DTM?

Reyhan_Sadaka
Level 4
Level 4

I have an Adobe Analytics implementation that I am extending to a new brand on the same site. We are performing an upgrade from H Code to JS code, and so there are currently two version of analytics existing in the QA environment (the H code version delivered by Tealium which is being phased out, and the JS version being delivered by DTM which is being phased in). The Analytics variable name has been correctly overridden to "sDtm" instead of just "s".

On this new brand however, I'm noticing 3 AA beacons when I only expect two. I would expect to see 1 old H Code beacon, and 1 new JS beacon, however I am seeing 1 old H Code beacon and 2 new JS beacons. When I check the Elements tab in Chrome, I find that two copies of s-code-contents-XXXXXXXXXXX-staging.js are being loaded on the page. So now I'm seeing one JS beacon from /b/ss/%ReportSuite%/1/JS-1.7.0-D6L7 and one from /b/ss/%ReportSuite/1/JS-1.7.0-D6ZS.

I need some help figuring out what circumstances might cause DTM to load the tool twice on the page. When I looked at the actual page source, I'm only seeing one call to the DTM staging library, and one call to _satellite.pageBottom(). The code has not been changed for the new brand implementation yet, and when I check the other brand pages I do not see this issue.

Any assistance would be appreciated.

1 Accepted Solution
jantzen_belliston-Adobe
Correct answer by
Level 10
Level 10

Hi Reyhan,

How is your Analytics tool deployed inside DTM? Are you using a customized library or managed by Adobe? Where are you hosting your Analytics JS code? Is that deployed to the site directly or through DTM? If it is already on the page, you may need to check the "Page code is already present" box. Otherwise, you may have the library being deployed twice which could cause a double beacon.

If you can send me a private message with your account details, I'll take a look at your setup to see if I see anything out of place.

Cheers,
Jantzen

View solution in original post

2 Replies
jantzen_belliston-Adobe
Correct answer by
Level 10
Level 10

Hi Reyhan,

How is your Analytics tool deployed inside DTM? Are you using a customized library or managed by Adobe? Where are you hosting your Analytics JS code? Is that deployed to the site directly or through DTM? If it is already on the page, you may need to check the "Page code is already present" box. Otherwise, you may have the library being deployed twice which could cause a double beacon.

If you can send me a private message with your account details, I'll take a look at your setup to see if I see anything out of place.

Cheers,
Jantzen

View solution in original post

ParitMittal
Level 10
Level 10

Hi Reyhan,

Does the above answers from Jantzen help's to answer your queries ?. If yes, Please go ahead and mark this query as resolved.

Thanks & Regards

Parit Mittal