Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Multiple Page Tags firing for a single Page load.(Using DTM)

Avatar

Level 1

Hi,

We noticed that there are multiple Omniture tags firing for a single page load in our Dev Environment. (can't share the URL)

  • 3 similar tags are firing for a single page load (All 3 tags have same page name & variables).
  • I can see DTM rules are fired thrice in the console.

I just wanted to check if you guys are aware of this and please share in case you have any insights on this.

PFA Screenshot.Capture.PNG

1 Accepted Solution

Avatar

Correct answer by
Level 5

Check to make sure you don't have multiple DTM headers or footers output to the page.  Also, are there any iframes which may also have DTM installed?

View solution in original post

5 Replies

Avatar

Level 10

How are you deploying your DTM embed codes? Are you using Akamai? Also, are you dynamically injecting the embed codes or are they loaded statically with the page?

Thanks,
Jantzen

Avatar

Level 1

Yes Jantzen, We are using Akamai staging for deployment. And we are dynamically injecting the embed codes.

Thanks,

Nischith.

Avatar

Correct answer by
Level 5

Check to make sure you don't have multiple DTM headers or footers output to the page.  Also, are there any iframes which may also have DTM installed?

Avatar

Level 10

As Mike said, check to make sure you don't have multiple _satillite objects on the page as a result of multiple embeds codes being injected into the page.

Technically, dynamically inserting the embed codes isn't a supported deployment method. With that said, I'm not saying it can't work.

Avatar

Level 10

Were you able to find a solution to this issue? If so, is there an answer that we can mark as correct in case others have a similar issue?