Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

ERROR TypeError: Cannot read property 'getS' of undefined

Avatar

Level 1

Has anyone else came across this issue before? It's a new one to me and have only found one other discussion where something similar has cropped up, but it went unresolved so wasn't much help!

Full error message on the following urls ( https://benchmarks.econsultancy.com and https://isd.econsultancy.com):

ERROR TypeError: Cannot read property 'getS' of undefined

    at Location.<anonymous> (satellite-5b87ed8d64746d2bd300a564.js:20)

    at i (satelliteLib-330de18b8d9326dabe4b8023f4a38cb1cb1dea38.js:11)

    at i (satelliteLib-330de18b8d9326dabe4b8023f4a38cb1cb1dea38.js:10)

    at HTMLScriptElement.onload.t.onload [as __zone_symbol__ON_PROPERTYload] (satelliteLib-330de18b8d9326dabe4b8023f4a38cb1cb1dea38.js:10)

    at HTMLScriptElement.E (polyfills.4277d8cf821576b964ae.bundle.js:1)

    at t.invokeTask (polyfills.4277d8cf821576b964ae.bundle.js:1)

    at Object.onInvokeTask (main.730b65d9a230f49f323a.bundle.js:1)

    at t.invokeTask (polyfills.4277d8cf821576b964ae.bundle.js:1)

    at n.runTask (polyfills.4277d8cf821576b964ae.bundle.js:1)

    at n.invokeTask [as invoke] (polyfills.4277d8cf821576b964ae.bundle.js:1)

1 Accepted Solution

Avatar

Correct answer by
Employee Advisor

I checked your site, and it looks like the subdomain of the image request is ex.%20site.omtrdc.net. This is preventing the domain from resolving. I believe that's managed by the tracking server field, so you'll want to update that to not have any spaces or periods.

Once that error is resolved, let me know so I can check the console and see if there are any other issues at hand.

View solution in original post

1 Reply

Avatar

Correct answer by
Employee Advisor

I checked your site, and it looks like the subdomain of the image request is ex.%20site.omtrdc.net. This is preventing the domain from resolving. I believe that's managed by the tracking server field, so you'll want to update that to not have any spaces or periods.

Once that error is resolved, let me know so I can check the console and see if there are any other issues at hand.