Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

DTM page load rule won't fire

Frank_Lee_-_UT
Level 2
Level 2

Hi,

 

I'm having trouble getting a page load rule to fire.  I'm using the staging tag on a dev server, and the basic Adobe Analytics fire on the page load through DTM.  The rule is configured to fire at the bottom of the page.  I've set the criteria using path and a regex defined as:    .indycar.   

(I'm trying to use criteria that fire for both the dev and prod servers)

A sample dev page is here:

http://dev.indycar.ims.com/news

 

Any suggestions are welcome.

 

Thanks!

Frank.

1 Accepted Solution
Frank_Lee_-_UT
Correct answer by
Level 2
Level 2

Hi Mike,

 

That does allow the rule to fire, but doesn't afford us the flexibility we need to write one rule for both the dev and prod environments. We're trying to format a global rule for all pages on the site.  Maybe I need to re-work the regex for the path statement.

Thanks!

View solution in original post

2 Replies
mikethompson
Level 5
Level 5

Frank,

Try using the subdomain criteria if you are matching indycar (path would be used for the news portion in your example).

Frank_Lee_-_UT
Correct answer by
Level 2
Level 2

Hi Mike,

 

That does allow the rule to fire, but doesn't afford us the flexibility we need to write one rule for both the dev and prod environments. We're trying to format a global rule for all pages on the site.  Maybe I need to re-work the regex for the path statement.

Thanks!

View solution in original post