Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

DTM: All links tracking as external

LAE
Level 2
Level 2

I am very new to DTM and am working on implementing Adobe Analytics in our staging environment. I am using just the base s_code, and am building things up a little at a time. I have some basic evars and props working fine, but I am currently having a problem where all internal links are being detected as external (everything is lnk_e), even though the subdomain is identical from link to link.

I have "Track Outbound Links" checked in the Link Tracking tab, but nothing in the "Always Track" box.  Do I need to enter anything there?  I can't find any documentation for what that actually does.

In Edit Property, I have only the single subdomain (call it stage.mysite.org) listed, and do not have "spans multiple domains" checked.

In addition, in the DTM-hosted s_code, I have:
s.trackExternalLinks=true

s.linkInternalFilters="javascript:,stage.mysite.org"

Do I have a conflict somewhere?  I don't really understand what I need to set in settings and what needs to be set in s_code -- and what overrides what or conflicts with what.

Does anyone have any suggestions?

Thanks!

1 Accepted Solution
salomepb
Correct answer by
Level 3
Level 3

Hi Leigh Ann,

We're currently exploring a potential conflict between setting s.linkInternalFilters in the hosted s_code versus in the available UI field 'Never Track' under 'Link Tracking' in your Adobe Analytics tool settings in DTM. You should be able to workaround this by entering the values you wish to set for s.linkInternalFilters as entries in the 'Never Track' field. 

I hope this helps! Just let me know if I've misunderstood the issue you're encountering in any way or if you have any questions.

Best,

Anna

View solution in original post

6 Replies
salomepb
Correct answer by
Level 3
Level 3

Hi Leigh Ann,

We're currently exploring a potential conflict between setting s.linkInternalFilters in the hosted s_code versus in the available UI field 'Never Track' under 'Link Tracking' in your Adobe Analytics tool settings in DTM. You should be able to workaround this by entering the values you wish to set for s.linkInternalFilters as entries in the 'Never Track' field. 

I hope this helps! Just let me know if I've misunderstood the issue you're encountering in any way or if you have any questions.

Best,

Anna

View solution in original post

LAE
Level 2
Level 2

Thanks, Anna!  That is exactly what I ended up doing before anyone replied. That did the trick.

I removed all code for the Link Tracking Config in the basic s_code I am using, and set them using the settings instead.  Worked like a charm.

Perhaps I'll do a bit of testing to see what happens if I have conflicting info in the settings versus the s_code.  But considering the s_code settings were not doing anything, I'm not sure there will be a conflict for me.

LAE
Level 2
Level 2

Hi Deep,
When you view one of your pages, have you looked at what is being set in s.linkInternalFilters? You can look at the value in the console and see if the link's domain is missing. See if it is the same as what's in your s_code, or if the DTM version is overwriting it.  (That's what was happening to me.)

Looking at what it is set fr s.linkInternalFilters might help figure out where the problem is.

deephazar
Level 1
Level 1

Hi Lae,

Thanks for your response. Yes, I checked and that's where I saw that there is a similarity in the issue. Domains in s_code are similar in the sense,

s.trackExternalLinks=true
s.linkInternalFilters="javascript:,my-domain.com"

while in DTM, the list of domains in Never Track are few more in addition to the ones declared in the s_code.

However, its worth noting that there are no exit links triggering in my staging servers, but only in the live site domain. It's the same property and so uses the same list of domains entered either in DTM Never Track list or s_code.

I am still checking where the issue could be. Any pointers would be great.

 

Thanks,

Deep

ParitMittal
Level 10
Level 10

Hi Deep,

Can you please share your DTM account details as well as test URL in a private message or Email (pamittal@adobe.com) so that we can reproduce and debug the issue at our end .

Thanks & Regards

Parit Mittal

deephazar
Level 1
Level 1

Hi Parit,

Thanks. I have sent a direct mail to you. In the meantime, I am also checking if "Customize Page Code" in the respective AA tool is not working accordingly. The tags firing from DTM are restricted to link clicks only, while page loads are being tracked using legacy Page code. I have written an updated javascript condition to be included in the Customize Page Code for a specific section of the site, but I am unclear why the spillover tags are triggering on other sections as well.

 

Best,

Deep