Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Uncaught SyntaxError: Unexpected token if

ridderm22429092
Level 1
Level 1

Hello,

I was wondering if anybody is getting the following:  when I try to access the test page in an incognito browser (Chrome), I'm getting a "Uncaught SyntaxError: Unexpected token if".  I tried this with IE and FF but only Chrome seems to be the one displaying the error.  When looking into the error, it looks like the source of the issue is typeof(s_tnt)=='undefined'.  The implementation of Target is standard, so no custom work was done.  If anybody have any insights on how to fix this, please let me know.  I'm including screenshots of the error.

Thanks,

Ridder H. Manzanet

1 Accepted Solution
jantzen_belliston-Adobe
Correct answer by
Community Manager
Community Manager

It's hard to tell without taking a deep look into the implementation. I would check to see if any of your other code libraries reference that variable. It might be possible that an old Analytics plug-in is referencing that variable from your s_code/AppMeasument library (if you an Analytics customer). If that doesn't turn anything up, I'd recommend opening a ticket with Target Customer Care. They can gather the necessary details for an in depth look into your implementation.

View solution in original post

4 Replies
jantzen_belliston-Adobe
Community Manager
Community Manager

Hi Ridder,

Can you tell me if you are using the legacy sc-tnt integration? Typically, that variable is used in the legacy integration which has been deprecated. I'd suggest looking into the newer A4T integration.

Thanks,
Jantzen

ridderm22429092
Level 1
Level 1

Thanks Jantzen for the quick reply.  The site doesn't have the sc-tnt integration implemented.  Anything else that I should be looking for?

Thanks,

Ridder H. Manzanet

jantzen_belliston-Adobe
Correct answer by
Community Manager
Community Manager

It's hard to tell without taking a deep look into the implementation. I would check to see if any of your other code libraries reference that variable. It might be possible that an old Analytics plug-in is referencing that variable from your s_code/AppMeasument library (if you an Analytics customer). If that doesn't turn anything up, I'd recommend opening a ticket with Target Customer Care. They can gather the necessary details for an in depth look into your implementation.

View solution in original post

ParitMittal
Level 10
Level 10

Hi Ridder,

Is the above issue resolved?

Thanks & Regards

Parit Mittal