Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Adobe Target now working when i use Hash parameter

miguelb82821298
Level 2
Level 2

Hello,

 

I am doing an A/B Test on our SPA website. It works perfect but when I add the HASH parameter in Audience Refinements it stops working. It does not inject my code.

 

Site Pages: Current Page URL contains
mywebsite.es
 
Site Pages: Current Page Hash (#) fragment contains
#mypage

 

¿What the reason could be?

 

Regards

1 Accepted Solution
TanviAgarwal89
Correct answer by
Level 4
Level 4

Hi @miguelb82821298,

 

When you create an activity in VEC, it tries to add the mboxEdit=1 and mboxDisable=1 as a query parameter in the URL, to be able to make the changes.

 

However with # fragment , this might not be possible.

 

I suggest creating an activity on homepage and use the #Hash fragment as an activity audience. Hope that works!

View solution in original post

1 Reply
TanviAgarwal89
Correct answer by
Level 4
Level 4

Hi @miguelb82821298,

 

When you create an activity in VEC, it tries to add the mboxEdit=1 and mboxDisable=1 as a query parameter in the URL, to be able to make the changes.

 

However with # fragment , this might not be possible.

 

I suggest creating an activity on homepage and use the #Hash fragment as an activity audience. Hope that works!

View solution in original post