Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Strange visibility problem

Avatar

Level 2

I have made a form with the following information

datasheet.jpg

if I go to preview and enter e.g. 5 for "number of spreaders ordered" then the subform/table "Series" will become visible, but

when I go to preview and first change radiobutton list "Certificate by certified body" and afterwards change "number of spreaders ordered" the subform/table "Series" will not become visible.

As far as I can see the RBL and subform/table "Series" are not connected and I know for sure I didn't connect them.

Can someone please help me to solve this strange behaviour?

the following script is behind the fields:

 

----- DataSheet.TechnicalInformation.GeneralInformation.nfQty::initialize: - (JavaScript, client) --

if (nfQty.rawValue == 1)

       {

       Singular.presence = "visible";

       Series.Series._rSeries.setInstances(Series.Series._rSeries.occur.initial);

       Series.Series.presence = "hidden";

       }

else if (nfQty.rawValue == 0)

       {

       nfQty.rawValue = "1";

       Singular.presence = "visible";

       Series.Series._rSeries.setInstances(Series.Series._rSeries.occur.initial);

       Series.Series.presence = "hidden";    

       }

else

       {

       Series.Series.presence = "visible";

       Series.Series._rSeries.setInstances(this.rawValue);

       Singular.presence = "hidden";

       }

----- DataSheet.TechnicalInformation.GeneralInformation.nfQty::exit: - (JavaScript, client) --------

GeneralInformation.nfQty.execEvent("initialize");

----- DataSheet.TechnicalInformation.Certification.Cert.rblCertBody::initialize: - (JavaScript, client)

if (rblCertBody.rawValue == 1)

       {

       Certification.CBOption.presence = "visible";

       }

else

       {

       Certification.CBOption.presence = "hidden";

       }

----- DataSheet.TechnicalInformation.Certification.Cert.rblCertBody::change: - (JavaScript, client)

Certification.Cert.rblCertBody.execEvent("initialize");

----- DataSheet.TechnicalInformation.Certification.CBOption.rblCBOption::change: - (JavaScript, client)

Certification.Cert.rblCertBody.execEvent("initialize");

1 Accepted Solution

Avatar

Correct answer by
Level 10

Few things I did..

1) You had placed the table Series wrapped under an other Subform with the same name. I removed the Subform and moved the table under General Information.

2) Since I removed the Series Subform, I have updated all the scripts you had referenced it.

Thanks

Srini

View solution in original post

0 Replies

Avatar

Level 10

Looking at form might help understand the issue..

Steps to share a document..

1. Go to URL http://Acrobat.com
2. Create an account if you don't have one.
3. Then login to the website.
4. In top left corner you will see a button called Upload.
5. Click on browse and select the file you want to upload.
6. After Uploading, mouse over on the uploaded file. Click the down arrow button and choose Share document.
7. Then you will be prompted a popup window at the lower left corner. Choose "Publish it" option.
8. In the next pop up window choose "Copy Link" option.
9. You can paste the link in the forum thread.

Thanks

Srini

Avatar

Level 2

can you tell me what you have done?

and if you know why did it act that way?

greetings Simone

Avatar

Correct answer by
Level 10

Few things I did..

1) You had placed the table Series wrapped under an other Subform with the same name. I removed the Subform and moved the table under General Information.

2) Since I removed the Series Subform, I have updated all the scripts you had referenced it.

Thanks

Srini