Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Form appears blank when submitted

clembj
Level 1
Level 1

I recently ran into an issue with a form newly created in Adobe Livecycle where the data from each of the form fields is erased when the user submits the form via email (as a pdf). The form itself is quite simple with 7 text fields, 2 date fields, and a button to submit the form via desktop email application. There is no JavaScript or FormCalc scripting.

I am using Adobe Licecyle Designer ES 8.2 on Windows 7. I have created several of these forms in the past with no such issues. Can anyone help?

Thanks,

Brandon

1 Accepted Solution
Bibhu_Bikash_Na
Correct answer by
Level 9
Level 9

The problem is due to data binding. None of your fields have data bindings. So when you submit the form it becomes blank. So you can change the data bindings as below.

Select the field > Object Palette > Binding > Data Binding > Select Use Name. For example : If the name of the field is Description then data binding would be Use name (Description).

I could have posted the form but some security restrictions here preventing me doing the same.

Thanks,

Bibhu.

View solution in original post

5 Replies
Bibhu_Bikash_Na
Level 9
Level 9

Hi Brandon,

It's difficult to tell what's happening without seeing the form? It could be due to many reasons. WHat about the data binding of those fields? Have you made the form as reader extended? Share your form, if possible.

Thanks,

Bibhu.

clembj
Level 1
Level 1

Here is a link to the document. I have extended the rights to Reader so that is not the issue but I am not familiar enough with data binding so that could be something to do with it.

https://workspaces.acrobat.com/?d=yjra5tZlKHXNdjjpEpfU0w

Thanks in advance!

Jono_Moore
Level 10
Level 10

In File>Form Properties>Defaults change "Preserve scripting changes to form when" to Automatically.

Bibhu_Bikash_Na
Correct answer by
Level 9
Level 9

The problem is due to data binding. None of your fields have data bindings. So when you submit the form it becomes blank. So you can change the data bindings as below.

Select the field > Object Palette > Binding > Data Binding > Select Use Name. For example : If the name of the field is Description then data binding would be Use name (Description).

I could have posted the form but some security restrictions here preventing me doing the same.

Thanks,

Bibhu.

View solution in original post

clembj
Level 1
Level 1

Thanks Bibhu, this worked perfectly! I love it when there's any easy fix.

Thanks,

Brandon