Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

Custom Render service is called only once, why?

Yan_Kliaver
Level 4
Level 4

Hi All,

I've created a custom render service in order to prepopulate principals name on each step of my process.

The input form of the process is a Document Form cause users attach files to the form and it is routed to next station with the attachments.

"Call Render Service only once" checkbox in advanced settings is unchecked.

When the process is initiated my custom render is invoked fine, but when it reaches the assign task activity the form is opened but no render service is invoked.

Why is it happens?

Thanks in advance, Yan.

1 Accepted Solution
parth_pandya
Correct answer by
Level 3
Level 3

Hi Yan,

Are you using the same 'form' variable in user step that you used in first step? I would suggest that you put the Variable Logger as the first step in your render process to check if it gets called several times or not.

Parth

View solution in original post

4 Replies
parth_pandya
Correct answer by
Level 3
Level 3

Hi Yan,

Are you using the same 'form' variable in user step that you used in first step? I would suggest that you put the Variable Logger as the first step in your render process to check if it gets called several times or not.

Parth

View solution in original post

Yan_Kliaver
Level 4
Level 4

Hi Parth,

I'm writing to the log file every time that my custom service is invoked.

When I open a form for a first time in workspace I see that it was invoked but when it reaches "assign task" activity and opened again the service is not invoked.

I have only one form variable.

Yan.

Jasmin_Charbonn
Level 10
Level 10

I forget the exact name, but I believe there is a "render only once" option when you configure the render service.

Jasmin

Yan_Kliaver
Level 4
Level 4

Before the assign task step the form was sent as an input to another process and then  returned as an output.

In this process the form was assigned to another one that was not configured to use custom render service.

Thanks a lot!