Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

ALC-LCM-030-112: Failed to deploy EAR

Avatar

Level 2

I’m trying to install LiveCycle on the following environment:

- Linux SUSE 10

- Oracle 10g

- Weblogic 11g

Configuration steps run free of problems until the Deploy LiveCycle ES2 EARs screen, where the following error message comes on:

erro1.JPG

erro2.JPG

erro3.JPG

[2011-04-25 16:12:56,015], SEVERE, Thread-55, com.adobe.livecycle.cdv.CDVException, Failed to deploy EAR.
Could not deploy adobe-livecycle-weblogic.ear.
com.adobe.livecycle.cdv.CDVException[ALC-LCM-030-112]: Failed to deploy EAR.
Could not deploy adobe-livecycle-weblogic.ear.
at com.adobe.livecycle.cdv.CDVException.handleException(CDVException.java:60)
at com.adobe.livecycle.cdv.deployer.WLDeployer.deployApp(WLDeployer.java:148)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.deployEARs(DeployEARs.java:164)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.deployLFSs(DeployEARs.java:99)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.deployLFSs(DeployEARs.java:90)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask$ActualTask.<init>(DeployEARsTask.java:92)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask$1.construct(DeployEARsTask.java:61)
at com.adobe.livecycle.lcm.core.tasks.SwingWorker$2.run(SwingWorker.java:114)
at java.lang.Thread.run(Thread.java:736)
Caused by: com.adobe.livecycle.cdv.CDVInternalException[ALC-LCM-100-000]: Could not deploy this application. Received fail
status
at com.adobe.livecycle.cdv.deployer.WLDeployer.deployApp(WLDeployer.java:143)
... 7 more
[2011-04-25 16:12:56,020], SEVERE, Thread-55, com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask, Task failed
com.adobe.livecycle.cdv.CDVException[ALC-LCM-030-112]: Failed to deploy EAR.

Could not deploy adobe-livecycle-weblogic.ear.
at com.adobe.livecycle.cdv.CDVException.handleException(CDVException.java:60)
at com.adobe.livecycle.cdv.deployer.WLDeployer.deployApp(WLDeployer.java:148)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.deployEARs(DeployEARs.java:164)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.deployLFSs(DeployEARs.java:99)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARs.deployLFSs(DeployEARs.java:90)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask$ActualTask.<init>(DeployEARsTask.java:92)
at com.adobe.livecycle.lcm.feature.deployment.DeployEARsTask$1.construct(DeployEARsTask.java:61)
at com.adobe.livecycle.lcm.core.tasks.SwingWorker$2.run(SwingWorker.java:114)
at java.lang.Thread.run(Thread.java:736)
Caused by: com.adobe.livecycle.cdv.CDVInternalException[ALC-LCM-100-000]: Could not deploy this application. Received fail
status
at com.adobe.livecycle.cdv.deployer.WLDeployer.deployApp(WLDeployer.java:143)

0 Replies

Avatar

Level 7

A variety of things can cause this.  If you have access to Adobe Technical Support, it'll be a good idea to get them to help you.

If not, try deploying these manually using the WebLogic Admin Console and see if you get better error messages.

Avatar

Level 2

These are some of the other messages genrated on the Weblogic log.

Does this help in any way?

####<Apr 26, 2011 4:09:35 PM BRT> <Error> <com.adobe.idp.dsc.registry.component.impl.ComponentStoreImpl> <lnx8.csn.com.br> <AdobeServer> <[ACTIVE] ExecuteThread: '5' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <BEA1-000E543F13E141CCC497> <c670ff48d84dd885:-7f7db98e:12f932f554b:-8000-0000000000000019> <1303844975996> <BEA-000000> <ComponentStoreImpl:getComponents:Exception:EJB Exception: ; nested exception is: javax.ejb.EJBException: EJB Exception: : java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

####<Apr 26, 2011 4:09:33 PM BRT> <Error> <HTTP> <lnx8.csn.com.br> <AdobeServer> <[ACTIVE] ExecuteThread: '5' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <c670ff48d84dd885:-7f7db98e:12f932f554b:-8000-0000000000000019> <1303844973109> <BEA-101216> <Servlet: "FormsServlet" failed to preload on startup in Web application: "/FormServer".
java.lang.NullPointerException

####<Apr 26, 2011 4:09:35 PM BRT> <Info> <EJB> <lnx8.csn.com.br> <AdobeServer> <[ACTIVE] ExecuteThread: '5' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <BEA1-000E543F13E141CCC497> <c670ff48d84dd885:-7f7db98e:12f932f554b:-8000-0000000000000019> <1303844975992> <BEA-010227> <EJB Exception occurred during invocation from home or business: com.adobe.pof.omapi.POFObjectManagerLocalBean_j8d0wl_LocalHomeImpl@1217776e threw exception: javax.ejb.EJBException: EJB Exception: : java.sql.SQLSyntaxErrorException: ORA-00942: table or view does not exist

<Apr 26, 2011 4:09:39 PM BRT> <Error> <Deployer> <BEA-149265> <Failure occurred in the execution of deployment request with ID '1303844929176' for task '9'. Error is: 'weblogic.application.ModuleException: [HTTP:101216]Servlet: "FormsServlet" failed to preload on startup in Web application: "/FormServer".
java.lang.NullPointerException
    at com.adobe.formServer.FormsServlet.expandArchive(FormsServlet.java:383)
    at com.adobe.formServer.FormsServlet.init(FormsServlet.java:69)
    at javax.servlet.GenericServlet.init(GenericServlet.java:241

<Apr 26, 2011 4:09:39 PM BRT> <Error> <Deployer> <BEA-149202> <Encountered an exception while attempting to commit the 1 task for the application 'adobe-livecycle-weblogic'.>

Avatar

Level 1

I had similar issue recently and resolved it using the workaround from IBM.

If you see entries like this on “SystemErr.log”, you may be having the same problem.

 

com.ibm.websphere.management.exception.AdminException: A composition unit with name LiveCycleES2 already exists. Select a different application name. 

Unable to publish application in WebSphere Commerce Developer 7.0”

http://www-304.ibm.com/support/docview.wss?uid=swg21449595

LiveCycle does not support this “Commerce Developer” so my guess is that this may be issue with come common components among different Websphere suit.

As Jayan mentioned, the error you see on LCM could be caused by several factors, so this is just one of such cases.