Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
BedrockMission!

Learn more

View all

Sign in to view all badges

SOLVED

ALC-FRM-901-001 Error in running server script Internal Server Error when preview in HTML5

tarekahf
Level 8
Level 8

I am getting errors when I preview form using Adobe LC ES4 patch 1 (upgraded from LC ES4 on a virtual machine).

First time using HTML5.

Initially, when try to preview a form in HTML5, we get this error:

939271_pastedImage_1.png

Then deleted several subforms to reduce number of object, and finally when I preview I get this error

939272_pastedImage_2.png

Then I get this error:

TypeError: Object ( object Object] has no method 'isRequestFromMIP'

939273_pastedImage_3.png

Then I get a blank page.

The problem is that I cannot tell where is the error exactly and how to pinpoint the location of the error to be able to debug and solve the problem.

Appreciate your help.

939270_pastedImage_0.png

1 Accepted Solution
Jovan_Ilievski
Correct answer by
Level 2
Level 2

Hi Tarek,

You may have already come across the answer to this solution, but I figured it would be helpful for other people who have the same question.  For the web service call to work you first need to deploy the form to the workspace before invoking the service.

For testing purposes, the web service call will work in PDF Preview if you use Acrobat as your PDF viewer (Not Reader).

Regards,

Jovan

View solution in original post

1 Reply
Jovan_Ilievski
Correct answer by
Level 2
Level 2

Hi Tarek,

You may have already come across the answer to this solution, but I figured it would be helpful for other people who have the same question.  For the web service call to work you first need to deploy the form to the workspace before invoking the service.

For testing purposes, the web service call will work in PDF Preview if you use Acrobat as your PDF viewer (Not Reader).

Regards,

Jovan

View solution in original post