Highlighted

XDP data transfer not working

Avatar

Avatar

Ryan_Lunka

Avatar

Ryan_Lunka

Ryan_Lunka

26-09-2008

Our process involves filling out a submission form, sending the data to the approval form, and then viewing that approval form. Essentially a simple submission and approval workflow.



When we export the XML of the approval form to see what data was passed in the schema, we see two sets of the XML. One is a bunch of empty nodes, except for the nodes tied to the process fields that show the connection with the approval form. The other set of nodes is an exact copy, only it contains the data, including the process field nodes that show it is from the submission form.



When one machine (running Acrobat 9 Pro) runs the process through Workspace, it works fine. When we export his approval form XML, we see that the first set of schema XML has the data. Because of this, the form can read it, populate itself, and everything is fine. It ignores the second set of nodes. When anyone on an a machine tries it using Acrobat 8.1 Pro the form does not load with the data. The exported XML shows that the first set of nodes is empty and the second has the data...so Acrobat can't find it.



Our setValue component that is supposed to transfer the data is set to (could this be an issue?)...

Location: process_data/ApprovalForm/object/data

Expression: process_data/SubmissionForm/object/data



Our requirements state that 8.1 has to work, so does anyone have any recommendations? Why is the XML getting doubled? Would the version of Acrobat change how Workspace functions? Thank you for any help you can provide us!

Replies

Highlighted

Avatar

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692
pguerett

29-09-2008

I think the issue is with your set value. I think you are making a copy of the data from one form var and copying it and not overwriting the other one. You will need to get down to a single data node and not 2. I am not an expert at xPath but if your expression was:



process_data/SubmissionForm/object/data/*



Then that would copy all nodes below the data node into the Location node. Or you could leave the expression the way it is and change the location to be process_data/SubmissionForm/object. I believe that woudl overwrite the data node in the location.