Highlighted

ValueObjects - Returning Array Objects Between CFC and Actionscript Class Object

Avatar

Avatar

ross_hibbert1

Avatar

ross_hibbert1

ross_hibbert1

18-11-2008

I have a class object ApplicationInfo.as and
ApplicationInfo.cfc mapped. I validated that all of the properties
in my .as class appears in the .cfc component. Within the
ApplicationInfo class, I have 3-4 array objects that pull all
addresses, comments, job history related to that ApplicationInfo
object, along with properties about the ApplicationInfo object (ie.
application_id, app_date, app_taken_by etc)



When I call the CFC, and debug it, I can see that all of the
Array objects in the CFC pull in all of the data, however, when I
return the object back to my flex app, via RemoteObject, all of the
ApplicationInfo properties appear (application_id, app_date,
app_taken_by etc), but all of my array objects are null.



Example of .as class



[Bindable]

public class ApplicationInfo

{

public var acApplicants:Array = new Array();

public var acProperties:ListProperties ;

public var acAssets:Array = new Array() ;

public var acDebtPayoffs:Array = new Array();

public var acQualifiedProducts:Array = new Array();

public var acComments:Array = new Array();

public var acQuickStats:Array = new Array();

public var reference_number:String = "";

public var status_id:Number = 0;





Example of CFC:



<cfcomponent output="false"
alias="MORTAPP.src.cfc.ApplicationInfo">

<cfproperty name="acApplicants" type="array" >

<cfproperty name="acProperties"
type="MORTAPP.src.cfc.ListProperties" >

<cfproperty name="acAssets" type="array" >

<cfproperty name="acDebtPayoffs" type="array" >

<cfproperty name="acQualifiedProducts" type="array" >

<cfproperty name="acComments" type="array" >

<cfproperty name="acQuickStats" type="array" >

<cfproperty name="reference_number" type="string"
default="">

<cfproperty name="status_id" type="numeric"
default="0">



Since I'm able to get the data back into the CFC and the
structure of all of arrays and objects within my ApplicationInfo
class look fine, I'm assuming it's the mapping between the CFC and
the .AS file. Any help is appreciated! Thanks!