Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Upgrading from FormServer 6 to 7

Avatar

Not applicable
Has anyone migrated their forms from version 6 to 7? If so, did it clear up any bugs, what was involved as far as development, and what other benefits have you noticed since the migration. It took a long time to get our 300+ forms migrated from FormFlow99 to LiveCycle forms 6, so we're wondering what will be involved with moving from 6 to 7.



Thanks!
7 Replies

Avatar

Not applicable
FormFlow 99 to LC Forms 6 was basically changing to a new product. LC Forms 6 to LC Forms 7 is just a version change. The API's are backwards compatible, so you shouldn't need to make much changes code wise. One thing I can think of is LC Forms 6 renders PDF 1.5, and by default LC Forms 7 will render PDF 1.6. So if you require PDF 1.5 (ie: your users are still on Acrobat 6.x) then you'll need to add the otpion "PDFVersion=1.5" to your renderForm call.



Of course, if you don't make changes to take advantage of some new features, like the renderAtClient option, you won't see as good performance improvements as someone who has designed their application with LC Forms 7 in mind.



Chris

Adobe Enterprise Developer Support

Avatar

Not applicable
Thanks for the response. You mentioned that we could carry out the upgrade if our users were stilling on Acrobat 6.x. Because of licensing issues we are going to stay on Acrobat 6 for some time and I set up a test server with LC 7 and when I render forms using Acrobat 6, I get a dialog stating the following:



"This PDF form requires a newer version of Adobe Acrobat..."



I modified my renderForm call to include "PDFVersion=1.5", and it didn't seem to make a difference. Is there another setting that I'm missing that might get rid of the popup. I am also having problems submitting data back to the server with this version of Acrobat.



Thanks!

Avatar

Not applicable
Okay, I fixed the issue with submitting data to the server. Everything is working fine with the forms except for that popup every time there is a round trip to the server. I'm hoping there's a way to get rid of that thing as it's a show stopper.



Thanks.

Avatar

Not applicable
If you click OK on that dialog it prompts you for an update to the Forms plug in. It does not update your Acrobat version. But that plugin update needs to be installed to get rid of that popup.



Chris

Adobe Enteprise Developer Support

Avatar

Not applicable
When I click on OK, I get another popup that says "No updates are available at this time." Is there another way I can go about installing the plugin?

Avatar

Not applicable
Hmm, I'm not sure. What version of Acrobat are you using?



Chris

Adobe Enterprise Developer Support

Avatar

Not applicable
I upgraded to 6.0.5 and it took care of the problem. Thanks for your help with this issue!



Chad