Highlighted

Problem with the path of field in process

Avatar

Guest

10-07-2008

Hi,

We have a problem about data/FSFIELD_ too.

To create the form we have used a wsdl connection.

And when we make a process we have :

/process_data/demandeForm/object/data/xdp/datasets/data/FSFIELDS_

So we can't acces to elments of the wsdl form.

When we execute the process nothing happend, so we think it's normal because we don't have acces to elements.

We have tried to change the path :

/process_data/demandeForm/object//data/form1/Body/getRequestState/in0,

using the xml schema of the form ( form1/Body/getRequestState/in0 )

and we tried /process_data/demandeForm/object//data/in0

but this solution doesn't work.

(in0 is the field name).

Have you any idea ? please

Replies

Highlighted

pguerett

11-07-2008

In the situation where no schema exists the process variable has no concept of the structure of the xml data that is being used. Hence it uses the FSFIELDS_ node as a placeholder for the root node. So if you know the path starting from the root to get to the node that you want then you can create an expression (by typing it in) that looks like this:



/process_data/demandeForm/object/data/xdp/datasets/data/FSFIELDS_/rootnode/next node/next node/target node



Or you can use the XPath ability to search for the node by using a double slash. Th eexpression woul look like this:



/process_data/demandeForm/object/data/xdp/datasets/data/FSFIELDS_//nodename