Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

NextGenRIA - Hosted VM image - mosaic icon

gareth_faulkner
Level 3
Level 3

In the hosted VM image there is no icon on the desktop as mentioned in the exercise guide.

Can someone confirm that the URL is just

http://localhost:8080/mosaic/#

When I run this, the mosaic flex app is loading, but the screen is blank....  I am not getting the login screen.

I have stopped the LC JBoss service and started the mosaic server.  I have run the ant task with no errors, and there are no errors in the Tomcat command window.

Gareth

13 Replies
Hodmi
Level 8
Level 8

Looks like the Mosaic Air client shortcut got removed some how.

You can access it by suing Start -> Programs -> Mosaic

As it states in the Exercise Guide on page 14, the connection URL for the AIR tool is http://localhost:8080 (no /mosaic/#).  If you use a different URL then you will see either an Off-Line or a Disconnected indicator beside the button at the bottom of the app.  You will also not see any apps in your list.

May I ask were you got the http://localhost:8080/mosaic/# URL?

Val_Snider-Lync
Level 3
Level 3

I'm going to assume this discussion has been resolved so I'm marking as assumed answered.

Cheers,

Val

gareth_faulkner
Level 3
Level 3

I did not realise the shortcut was to an AIR app, I was trying http://localhost:8080/mosaic directly into a browser.

Anyway, I have now tried it via the air app using the start menu shortcut (administrator/ password/ http://localhost:8080) and when I click Connect nothing is happening....

No errors in the logs as far as I can tell, and when I ran the ant script there were no errors either.  This could be a problem with just the hosted VM, so has anyone else using the hosted VM got it to work?

Gareth

Keishichi
Level 2
Level 2

I'm getting exact same issue with Mosaic AIR application - nothing happens after clicking "Connect" button with three inputs.

Gareth - did you find out what the reason is?

Thx,

Keishichi

Hodmi
Level 8
Level 8

There are a few of things to check:

1 - Did you shutdown the LiveCycle server?

2 - Did you start the Mosaic server?

3 - Are there any errors in the Mosaic Server window?

4 - When you login using the Mosaic Client do you see an "off-line" or "disconnected" note at the bottom of the interface (next to the button)?

5 - Did you run the ANT script after the Mosaic Server was running?

gareth_faulkner
Level 3
Level 3

1. Yes

2. Yes

3. No

4. No visible changes in the AIR app

5. Yes, and it ran with no errors

Gareth Faulkner

Hodmi
Level 8
Level 8

Hummm, very interesting.

Would you have a bit of time today to do a Connect session?  I'd like to see what is going on.

Hodmi
Level 8
Level 8

One more thing to try:

In a command prompt cd to C:\MAX2009\Next Gen RIAs\Server\9.0.0.0.20090828.2.219456\dist\samples and run ANT.  This will install the base product samples.

Then close and restart your Mosaic Client application (changes arn't picked up until restart).

Hodmi
Level 8
Level 8

Hi Gareth and Keishichi;

I did a connect session with Keishichi and it looks like I misunderstood the problem.  I thought you wern't able to see your applications when you logged in.  After seeing what's happening with Keishichi's server I realize that you don't get any response from the AIR client at all.

We did a reinstall of the AIR client to no avail.

I did some checking and the hosted image is located in Ottawa.  My thought is that there is either a time delay or a time-out when trying to connect from the Asia-PAC region (I noticed that you were in Australia and Japan respectively).

Val_Snider-Lync
Level 3
Level 3

I'm going to flag this as assumed answered.

Cheers,

Val