Highlighted

LiveCycle ES Connector for IBM Content Manager connection problem

Avatar

30-03-2009

I've recently installed Adobe LiveCycle ES 8.2.1 and we're trying to get the Connector for IBM CM working. First off here's what software levels we're using:



LiveCycle ES 8.2.1

WebSphere Network Deployment 6.1.0.21

IBM HTTP Server 6.1.0.21

IBM DB2 UDB 9.1(FP 6a)

IBM Content Manager 8.4

IBM Information Integrator for Content 8.4

Java JRE 1.5(SR 8a)



Our application(s) connect to our databases remotely. The DBs reside on our z/OS(which is at level 8.1)



When I try and enter in the database/datastore info in the Connector fields under services I get this error in LiveCycle



Failed to save settings.

Error: Not able to validate the connection with the IBM CM. Either credentials or database is wrong.For more information see the exception stack trace.



and I see the following in the SystemOut.log



[3/30/09 9:51:44:516 EDT] 00000039 IBMConnection E com.adobe.livecycle.connectorforibmcm.config.ejb.IBMConnectionInfoSessionBean testCEConnection ALC-DSC-003-

000: com.adobe.idp.dsc.DSCInvocationException: Invocation error.

at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:152)

at com.adobe.idp.dsc.interceptor.impl.InvocationInterceptor.intercept(InvocationInterceptor.java:140)

at com.adobe.idp.dsc.interceptor.impl.RequestInterceptorChainImpl.proceed(RequestInterceptorChainImpl.java:60)

at com.adobe.idp.dsc.transaction.interceptor.TransactionInterceptor$1.doInTransaction(TransactionInterceptor.java:74)

....



As well as the following:



[3/30/09 9:51:44:547 EDT] 00000039 ExceptionUtil E CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "setConnectionInf

o" on bean "BeanId(LiveCycle8#adobe-ibmcmconnector-config-ejb.jar#IBMConnectorConfigEJB, null)". Exception data: java.rmi.RemoteException: Unable to save the

configuration settings in Database; nested exception is:

com.adobe.livecycle.connectorforibmcm.config.IBMConnectionInfoException

at com.adobe.livecycle.connectorforibmcm.config.ejb.IBMConnectionInfoSessionBean.setConnectionInfo(IBMConnectionInfoSessionBean.java:120)

at com.adobe.livecycle.connectorforibmcm.config.intfs.EJSRemoteStatelessIBMConnectorConfigEJB_019262e6.setConnectionInfo(Unknown Source)

at com.adobe.livecycle.connectorforibmcm.config.intfs._IBMConnectionInfoRemote_Stub.setConnectionInfo(_IBMConnectionInfoRemote_Stub.java:347)

at com.adobe.livecycle.connectorforibmcm.admin.FsUiConfigBean.initFS(FsUiConfigBean.java:58)

...



The server can connect via DB2/command line to the z/OS without a problem and the datasources within WebSphere test connect to the databases without any problem as well. Any help is much appreciated. I can provide any additional details upon request.



Thank you in advance



~Regards

Nick

Replies

Highlighted

Avatar

Avatar

wasifp

Avatar

wasifp

wasifp

21-04-2009

Nick,

I am getting the exact same error. I have tried installing Adobe Livecycle 8 on two separate machines and they both give the same problem. In viewing at the logs, it seems that the IBM CM jar files are not being recognized by the Adobe installation. For me, I get the following logs as well in addition to what you see.

Caused by: java.lang.NoClassDefFoundError: com.ibm.mm.sdk.common.DKDDO
at java.lang.J9VMInternals.verifyImpl(Native Method)
at java.lang.J9VMInternals.verify(J9VMInternals.java:59)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:120)
at com.adobe.livecycle.connectorforibmcm.dsc.crc.CRCServiceDelegate.testIBMCMConnection(CRCServiceDelegate.java:58)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:615)
at com.adobe.idp.dsc.component.impl.DefaultPOJOInvokerImpl.invoke(DefaultPOJOInvokerImpl.java:118)
... 70 more

[4/20/09 19:34:56:339 CDT] 00

The DKDDO class is in the jar files that are inside II4C installation folder. I think that the file

"adobe-component-ext.properties" that they ask us to create to reference the IBM CM jars is not being picked up by the Adobe Connectors for IBM CM. Do you see the " java.lang.NoClassDefFoundError" in your logs? Any resolutions you had regarding this.

I even tried to copy the ibm jars to various paths and copied the props files ad various different locations. I am under the impression that the documentation may not have been updated for this change.

Highlighted

Avatar

Avatar

wasifp

Avatar

wasifp

wasifp

29-04-2009

Anyone tried using IBM Content Manager Connector from Adobe Livecycle forms server? I still can't get it working. It seems that the connector can not find my jar files that I have referenced in the properties file it asks to create.