Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

Invoke operation not found

Avatar

Level 8
Level 8
Hi all,



I have a problem invoking a small process inside a bigger process. I get the following error:

2007-12-10 14:38:00,206 ERROR [com.adobe.workflow.AWS] stalling action-instance: 4545 with message: ALC-DSC-121-000: com.adobe.idp.dsc.registry.InputParameterNotFoundException: Operation: invoke not found on service: Send mails to receiver

at com.adobe.idp.dsc.registry.infomodel.impl.OperationImpl.getInputParameter(OperationImpl.java:175)

at com.adobe.workflow.engine.PEUtil.invokeAction(PEUtil.java:480)

at com.adobe.workflow.engine.ProcessEngineBMTBean.continueBranchAtAction(ProcessEngineBMTBean.java:2881)

at com.adobe.workflow.engine.ProcessEngineBMTBean.asyncContinueBranchCommand(ProcessEngineBMTBean.java:2380)

at sun.reflect.GeneratedMethodAccessor898.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)



I can understand the error, but I don't know what I can do to fix the problem. The process is activated and I have set invoke permissions to the process creator. However I still get this error.



Hope you can help.



Sincerely

Kim Christensen
7 Replies

Avatar

Level 10
Does you "smaller" process contain Input variables. Are you providing the value for the inputs parameters when you call the "smaller" process from the "bigger" process.



How are you invoking the "smaller" process from the "bigger" process. Are you just dragging the "smaller" process's service on the "bigger" process? Are you using the web service interface?



Jasmin

Avatar

Level 8
Level 8
Yes, my "smaller" workflow has got alot (5) input variables and I belive I have set them correct.



Yes I drag the invoke (for Send email to receiver) directly to the bigger process.



i am not using the web service interface.



Sincerely

Kim Christensen

Avatar

Level 8
Level 8
I don't know why this error occurs. I have tried to restart the serer and deactivating and reactivating the service. What else can I try to debug the problem?



Thanks in advance



Sincerely

Kim Christensen

Avatar

Level 8
Level 8
I figured it out...



The problem was that I had made changes to the smaller process. These changes does apparently not apply until I put a new "invoke" into the bigger process. With this done the process worked perfectly...



Sincerely

Kim Christensen

Avatar

Level 3
I have the same problem.

But putting the sub process again did not work.

Please help!



Sedat,

Avatar

Level 3
I experienced the same problem. Did what Kim suggested--remove and re-insert the smaller process into the bigger process--and the exception went away.



Thank you,

Jesse

Avatar

Level 1

Before your last process put "SetValue" box. Set location variable to the same expression variable

It should work.