Highlighted

Form will not render from Workspace

Avatar

Avatar

JoshDBoyle-DVzR

Avatar

JoshDBoyle-DVzR

JoshDBoyle-DVzR

07-08-2008

I have an xfaForm that will be filled out to kick off a workflow via a TaskManager endpoint. However, when I try to start the workflow from within Workspace, it throws the following error code at me:



ALC-WKS-007-040



I have triple checked that my form and workflow meet the following criteria:



1) The variable I am using for my form is of type xfaForm

2) The variable I am using for my form is set to both "Input" and "Required"

3) The render service for the form is set to "Default Render" (invoke)

4) A button exists on the form and is set to "Submit"



I was under the impression that should the above for criteria be met, that a form should render but am I missing something?



Thanks in advance!

Replies

Highlighted

Avatar

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692
pguerett

07-08-2008

I believe the issue is your renderer. Which version of LC are you using?
Highlighted

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

07-08-2008

Are you using an XDP or a PDF in your xfaForm variable.



You can't use the Default Render with an XDP. You need to use the RenderPDFForm from Samples - Forms (in 8.0.1) or within Process Management (ES update 1)



Jasmin
Highlighted

Avatar

Avatar

JoshDBoyle-DVzR

Avatar

JoshDBoyle-DVzR

JoshDBoyle-DVzR

07-08-2008

To Paul:



I am using 8.1 and am using the Default Render renderer.



To Jasmin:



I am using a PDF in my xfaForm variable.
Highlighted

Avatar

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692

Avatar

pguerett

Total Posts

7.7K

Likes

611

Correct Answer

692
pguerett

07-08-2008

If you want to stick with a PDF then you will need a docForm not an XFAForm variable. And you can use the default renderer with that one. If you want to stick with your xfaForm then you will have to use an XDP with the sample renderer that Jasmin mentioned.
Highlighted

Avatar

Avatar

JoshDBoyle-DVzR

Avatar

JoshDBoyle-DVzR

JoshDBoyle-DVzR

08-08-2008

Paul



I tried making my xfaForm variable into a Document Form variable. I then saved my process, logged back into Workspace and kicked off the workflow only to get the following error (different from above):



ALC-WKS-007-027



Are you sure that you can't render an xfaForm variable using the Default Render process? I am confident I have done so before.



EDIT: I just created a new workflow in a completely seperate environment that uses an xfaForm variable with a dynamic PDF as Input and Required and it rendered fine.



I think something is up with my client's Forms ES.
Highlighted

Avatar

Avatar

JoshDBoyle-DVzR

Avatar

JoshDBoyle-DVzR

JoshDBoyle-DVzR

08-08-2008

I just tried saving the form as an XDP and storing it in an xfaForm variable. Regardless of which render service I use (the Samples Render PDF or Default Render), the form will not render.
Highlighted

Avatar

Avatar

JoshDBoyle-DVzR

Avatar

JoshDBoyle-DVzR

JoshDBoyle-DVzR

08-08-2008

Problem solved - and all it took was a restart of Jboss.



The issue (and I'm not 100% clear about the "why" and "when" of it) is that Forms ES just stopped being able to render forms properly. As I stated, restarting JBoss fixed the issue (whatever it was).
Highlighted

Avatar

Avatar

_Nith_

Avatar

_Nith_

_Nith_

22-06-2009

Jasmin

I was trying to use a XDP form and the RenderPDFForm service (as you mentioned here). but i'm still getting error in rendering xdp file.

But i dono what values to be set for the following input variables:

formURL

inputDataDoc

serverEmail

targetURL

taskId

userAgent

for the outFormDoc i'm selecting Document.

could you pls help me on this?

Nith

Highlighted

Avatar

Avatar

Jasmin_Charbonn

Avatar

Jasmin_Charbonn

Jasmin_Charbonn

22-06-2009

Please do a search for RenderPDFForm in the Workbench help.

All the parameters are explained.

Jasmin