[Adobe Analytics] Cannot set variables, cannot send beacon, cannot clear variables

Avatar

Avatar
Validate 1
Level 1
santoshp9709432
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
santoshp9709432
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile
santoshp9709432
Level 1

19-02-2019

I have created a rule for adobe analytics extension and have configured analytics variables with test values for ex: pagename: "homepage", channel: "channel". The rule is firing but it cannot set variable, not sending beacon, neither clearing variable with error as "Cannot read property 'indexOf' of undefined". Below is the console screenshot for reference.

cort issue.PNG

Any help?

Accepted Solutions (1)

Accepted Solutions (1)

Avatar

Avatar
Validate 1
Level 1
santoshp9709432
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
santoshp9709432
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile
santoshp9709432
Level 1

21-02-2019

It was an issue with Adobe Analytics Extension, just upgraded it and this issue got solved.

Answers (4)

Answers (4)

Avatar

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

538 likes

Total Posts

973 posts

Correct reply

264 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

538 likes

Total Posts

973 posts

Correct reply

264 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile
Andrey_Osadchuk
MVP

21-02-2019

Can you share the URL (here or in direct message)?

Avatar

Avatar
Validate 1
Level 1
santoshp9709432
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile

Avatar
Validate 1
Level 1
santoshp9709432
Level 1

Likes

0 likes

Total Posts

3 posts

Correct reply

1 solution
Top badges earned
Validate 1
Affirm 1
View profile
santoshp9709432
Level 1

21-02-2019

Nowhere I've used indexOf method. I didn't coded anything in custom code.

Avatar

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

538 likes

Total Posts

973 posts

Correct reply

264 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile

Avatar
Shape 25
MVP
Andrey_Osadchuk
MVP

Likes

538 likes

Total Posts

973 posts

Correct reply

264 solutions
Top badges earned
Shape 25
Bedrock
Coach
Boost 500
Affirm 250
View profile
Andrey_Osadchuk
MVP

21-02-2019

Did you use any custom code with indexOf? if yes, could you share the code snippet?

Avatar

Avatar
Validate 1
Level 8
thomas_amsler
Level 8

Likes

244 likes

Total Posts

159 posts

Correct reply

26 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 25
View profile

Avatar
Validate 1
Level 8
thomas_amsler
Level 8

Likes

244 likes

Total Posts

159 posts

Correct reply

26 solutions
Top badges earned
Validate 1
Boost 50
Boost 5
Boost 3
Boost 25
View profile
thomas_amsler
Level 8

21-02-2019

Seems that you are missing the AppMeasurement.js library. Are you sure it is loaded correctly? Do you include your scripts async, maybe your rule is fired before the AppMeasurement is available.