Your achievements

Level 1

0% to

Level 2

Tip /
Sign in

Sign in to Community

to gain points, level up, and earn exciting badges like the new
Bedrock Mission!

Learn more

View all

Sign in to view all badges

SOLVED

Workflow Email Notification pointing to wrong url

Avatar

Level 3

We recently migrated to AEM 6.4 and noticed all OOB workflow Email notification body content which also has URL mentioned pointing to local-host URL on all environments (dev,stage, prod)

This was working on prior AEM version we were on (6.1) and We do have OSGI Link Externalizer Config properly setup for all run modes on 6.4

1580148_pastedImage_2.png

Apart from externalizer, We do have   Day CQ Workflow Email Notification Service (com.day.cq.workflow.impl.email.EMailNotificationService) configured with correct values for Dev/stage/prod but its also not helping.

Can anyone tell if its a product bug or required additional configuration ?

1 Accepted Solution

Avatar

Correct answer by
Level 10

Our support team replied:

Ok, so when I tested with Externalizer then the setting is ignored. Whenever I use Host URL Prefix from Host URL Prefix

It changes the prefix.

Might a good idea to log a support case

View solution in original post

0 Replies

Avatar

Level 10

It was closed because a customer support agent asked you open a ticket. They said they saw an issue. Once we get confirmation from support- we typically close the thread. There is nothing more we can do here - this is a bug. Did you log a ticket?

Avatar

Level 2

What's use of 'local' in Domains? I updated local URL from localhost to author-dev and the email have that URL. Will it break something?

 

cc. @smacdonald2008 

Avatar

Level 1

@anuj_pathak1 Were you able to resolve this bug with OOTB Workflow template not honoring the externalizer domain mapping? We are implementing this for one of the projects and need no customization of templates and unfortunately it doesn't work fine even in AEM 6.5.4. 

 

Any pointers would be helpful!

Avatar

Level 2
Did you try updating local to map to author URL? I tried that it started pointing to correct URL

Avatar

Level 2

Would love to know too, as on 6.5.8 this is an issue with Task Notifications too.

 

3 Years, and never officially fixed