Expand my Community achievements bar.

Enhance your AEM Assets & Boost Your Development: [AEM Gems | June 19, 2024] Improving the Developer Experience with New APIs and Events
SOLVED

While creating maven project i am getting this kind of error

Avatar

Level 3

 

The command which i used is :
mvn -B archetype:generate -D archetypeGroupId=com.adobe.aem -D archetypeArtifactId=aem-project-archetype -D archetypeVersion=26 -D appTitle="My Project" -D appId="aempanda" -D groupId="com.aempanda.aem" -D artifactId="myproject-aem-panda" -D version="0.0.1-SNAPSHOT" -D aemVersion="6.5.17" -D includeDispatcherConfig=n -D includeExamples=n -DfrontendModule=none

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

@monish_gavali 

Please try with command

 

mvn clean install -PautoInstallPackage -Padobe-public

 


Aanchal Sikka

View solution in original post

9 Replies

Avatar

Community Advisor

Hello @monish_gavali ,

Maybe you mismatched the archetype version with the AEM version. Check this compatibility chart: https://github.com/adobe/aem-project-archetype/blob/develop/VERSIONS.md 
If any confusion mention your command and other environmental details.
A sample command for you, Change the version according to your AEM setup.

 

mvn -B org.apache.maven.plugins:maven-archetype-plugin:3.2.1:generate \
    -D archetypeGroupId=com.adobe.aem \
    -D archetypeArtifactId=aem-project-archetype \
    -D archetypeVersion=43 \
    -D appTitle="AEM Demo" \
    -D appId="aem-demo \
    -D groupId="com.aem.demo" \
    -D artifactId="aem-demo" \
    -D package="com.aem.demo" \
    -D version="0.0.1-SNAPSHOT" \
    -D aemVersion="6.5.17"

 

UPDATE:

So the problem is in your archetype version. You are using AEM version 6.5.17 & archetype version 26.
According to the version compatibility, the minimum version will support 28.
But I will suggest using the latest one 43.

Avatar

Community Advisor

Please follow my given command. Hope it will be solved. The only problem was in your archetype version.

Avatar

Community Advisor

Hello @monish_gavali 

 

You are using a very old archtype. Latest is 43. https://github.com/adobe/aem-project-archetype

 

The documentation suggests command and the params as well. The documentation suggests aemVersion=6.5.7 for On-premise

 

Please cross-check, if its an issue on using 6.5.17


Aanchal Sikka

Avatar

Correct answer by
Community Advisor

@monish_gavali 

Please try with command

 

mvn clean install -PautoInstallPackage -Padobe-public

 


Aanchal Sikka

Avatar

Level 2

Hi @monish_gavali 

I understand how frustrating it can be to encounter technical difficulties. I went through a similar problem just yesterday.

The latest versions of Java (11.0.19) and mvn (3.9.3) with the specified command below [as @Sady_Rifat  mentioned as well]

 

mvn -B org.apache.maven.plugins:maven-archetype-plugin:3.2.1:generate \
    -D archetypeGroupId=com.adobe.aem \
    -D archetypeArtifactId=aem-project-archetype \
    -D archetypeVersion=43 \
    -D appTitle="WKND Sites Project" \
    -D appId="wknd" \
    -D groupId="com.adobe.aem.guides" \
    -D artifactId="aem-guides-wknd" \
    -D package="com.adobe.aem.guides.wknd" \
    -D version="0.0.1-SNAPSHOT" \
    -D aemVersion="6.5.17"

 

I trust that this will help you resolve the issue as well.