Expand my Community achievements bar.

Learn about Edge Delivery Services in upcoming GEM session
SOLVED

Unable to load wknd project and core components with latest AEM and Project Archetype

Avatar

Level 2

Hello everyone,

I am new to the AEM ecosystem and have recently attempted to install AEM quick start with author and publish environments. Everything appears to be working fine and I am able to view the retail site.

I am currently following this link

https://experienceleague.adobe.com/docs/experience-manager-learn/getting-started-wknd-tutorial-devel... to set up my project. However, after generating AEM for the wknd project, I am encountering dependency issues with core components and wknd sites as indicated below:

 

com.adobe.aem.guides.wknd.core.filters,version=[1.0,2) from aem-guides-wknd.core (590)
com.adobe.aem.guides.wknd.core.listeners,version=[1.0,2) from aem-guides-wknd.core (590)
com.adobe.aem.guides.wknd.core.schedulers,version=[1.0,2) from aem-guides-wknd.core (590)
com.adobe.aem.guides.wknd.core.servlets,version=[1.0,2) from aem-guides-wknd.core (590)
com.day.cq.wcm.api,version=[1.29,2) -- Cannot be resolved
javax.annotation,version=0.0.0 from org.apache.geronimo.specs.geronimo-annotation_1.3_spec (2)
javax.servlet,version=[3.1,4) from org.apache.felix.http.servlet-api (52)
org.apache.sling.api,version=[2.3,3) from org.apache.sling.api (77)
org.apache.sling.api.request,version=[2.4,3) from org.apache.sling.api (77)
org.apache.sling.api.resource,version=[2.12,3) -- Cannot be resolved
org.apache.sling.api.resource.observation,version=[1.2,2) from org.apache.sling.api (77)
org.apache.sling.api.servlets,version=[2.3,3) -- Cannot be resolved
org.apache.sling.models.annotations,version=[1.5,2) from org.apache.sling.models.api (543)
org.apache.sling.models.annotations.injectorspecific,version=[1.1,2) from org.apache.sling.models.api (543)
org.slf4j,version=[1.7,2) from slf4j.api (7)

 

com.day.cq.wcm.api,version=[1.29,2) -- Cannot be resolved
org.apache.sling.api.resource,version=[2.12,3) -- Cannot be resolved
org.apache.sling.api.servlets,version=[2.3,3) -- Cannot be resolved

Java and mvn version 
java -> 

java 11.0.19 2023-04-18 LTS

Java(TM) SE Runtime Environment 18.9 (build 11.0.19+9-LTS-224)

Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.19+9-LTS-224, mixed mode)
Maven 

Apache Maven 3.9.3 (21122926829f1ead511c958d89bd2f672198ae9f)

Generated project like 

 

mvn -B org.apache.maven.plugins:maven-archetype-plugin:3.2.1:generate \

    -D archetypeGroupId=com.adobe.aem \

    -D archetypeArtifactId=aem-project-archetype \

    -D archetypeVersion=43 \

    -D appTitle="WKND Sites Project" \

    -D appId="wknd" \

    -D groupId="com.adobe.aem.guides" \

    -D artifactId="aem-guides-wknd" \

    -D package="com.adobe.aem.guides.wknd" \

    -D version="0.0.1-SNAPSHOT" \

    -D aemVersion="6.5.17"

 

I could use some assistance in getting unblocked. Any help would be greatly appreciated.

1 Accepted Solution

Avatar

Correct answer by
Community Advisor

hello @rohitya2 

 

Please visit Software Distribution https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html?package=/content/... 

 

Download the package and Install it Via Package manager http://localhost:4502/crx/packmgr/

 

It will take some time. Please tail error.log for activity. Once it stabilizes a bit, please validate if the dependency errors aee resolved/


Aanchal Sikka

View solution in original post

13 Replies

Avatar

Community Advisor

Hello @rohitya2 

 

Can you please share the following details? 

- AEM version

- Service pack used

 

The errors mean that there is a mismatch in the dependency that the code is expecting and whats available in AEM.  

 

Please assure that you are on AEM 6.5 + Service Pack 17. The maven command used has "6.5.17" as aemVersion


Aanchal Sikka

Avatar

Level 2

AEM version:- 

Adobe Experience Manager (6.5.0) -> coming from [http://localhost:4502/system/console/status-productinfo]

In the command, I specified version 6.5.17, but I am unsure how to install the service pack for version 17. You mentioned sharing any helpful documentation or links, which would be greatly appreciated.

Avatar

Correct answer by
Community Advisor

hello @rohitya2 

 

Please visit Software Distribution https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html?package=/content/... 

 

Download the package and Install it Via Package manager http://localhost:4502/crx/packmgr/

 

It will take some time. Please tail error.log for activity. Once it stabilizes a bit, please validate if the dependency errors aee resolved/


Aanchal Sikka

Avatar

Community Advisor

Hello @rohitya2  - 

 

  • I can see that you used AEM Version as "6.5.17" but do you have the service package also installed on AEM instance?
  • Also, as per the tutorial link you shared it says, this tutorial uses the Maven AEM Project Archetype 35. However, you are using AEM archetype Version as 43

Correcting these should be solving the problem.

 

 

Avatar

Level 2

Hello @Tanika02, I have tried using the version specified in the documentation, but unfortunately, I encountered the same error. After conducting further investigation, I discovered new releases and their compatibilities. As a result, I adjusted the script to generate the project based on versions 43 and 6.5.17.

Avatar

Community Advisor

Okay!

 

@rohitya2  - Try cloning the Wknd site code and doing a build and see if it is getting successful. 

 

So basically, don't create an archetype project rather clone the wknd code from git and build https://github.com/adobe/aem-guides-wknd 

 

Have you tried this already?

Avatar

Community Advisor

I did tried this & the build is going successful. Check this should help.

 

Let me know if you face further difficulties.

Avatar

Level 2

Hi @Tanika02  I tried this and the build was successful however in the web console errors are still there and so when trying to access the wknd site it fails with same error as before 

Avatar

Community Advisor

Hi @rohitya2 

Please align your environment with the Adobe recommendation for the latest archetype.

AsifChowdhury_0-1690789725095.png

Archetype Historical Supported AEM Versions: https://github.com/adobe/aem-project-archetype/blob/develop/VERSIONS.md 

Avatar

Level 2

Hi ,@AsifChowdhury, You're spot on. To make sure we're in sync with 43, we're using these versions

Java -> 11.0.19
mvn -> 3.9.3
AEM -> 6.5.17 [in the script]

Avatar

Community Advisor

Hello @rohitya2 ,

With the previous discussion, you have a problem with the archetype and AEM SP version.

You can get confirmation with your SP version. Based on this version you need to setup your AEM project. For this you can check this documentation: https://github.com/adobe/aem-project-archetype/blob/develop/VERSIONS.md 

Sady_Rifat_0-1690790181968.png

However, If your SP version is not the latest one you can download it from Software Distribution. 

Sady_Rifat_1-1690790318728.png

https://experience.adobe.com/#/downloads/content/software-distribution/en/aem.html?package=/content/... 

To access this link may be you don't have that permission, ask your PM or Lead to download this for you.

Hope this helps you.