Expand my Community achievements bar.

July 31st AEM Gems Webinar: Elevate your AEM development to master the integration of private GitHub repositories within AEM Cloud Manager.
SOLVED

Website is not rendering CSS and designs

Avatar

Level 3

In our Dispatcher, designs for the website pages are present in the path /etc/docroot/mysiteWhenever we are open any page, in the console it is not loading the path of the designs (/etc/docroot/mysite). We found that the pages loads only the content but not the Css and designs. Please find the attached screenshot for one which is working fine and the other not working. We have checked the dispatcher settings as well by adding the rule to allow folders under /etc but it didnt worked out. Please provide your suggestions.

Similarly, in our Publish Instance the above mentioned issue is occuring whenever we tried to load any page without logging into the Publish Instance. But, if we logged-in and refresh the page, everything is working fine as expected. Not sure why the external users without logging into the publish instance are facing the above mentioned issue.

 

Update 1: While hitting the console I am getting the following error:

 http://my-dev.website.com/etc/clientcontext/legacy/config.json?path=%2F&cq_ck=1465275433288 404 (Not Found)

1 Accepted Solution

Avatar

Correct answer by
Level 10

Give the 'read' permission to the group 'everyone' for the path in the publish instance. Hope that should fix the issue.

View solution in original post

5 Replies

Avatar

Employee Advisor

Check whether annonymous has read permission on /etc/docroot folder on publish instance. 

Avatar

Correct answer by
Level 10

Give the 'read' permission to the group 'everyone' for the path in the publish instance. Hope that should fix the issue.

Avatar

Level 3

Hi Kunal,

Thank you,

We have checked the permission for the anonymous user & everyone group and provided all the accesses but still the designs are not loading.

Avatar

Level 3

Hi Lokesh

Thank you,

We have checked the permission for the anonymous user & everyone group and provided all the accesses but still the designs are not loading.

Avatar

Level 3

this was the issue after all, thanks a lot !